Can't revoke access grant using uplink cli


How can I revoke access grant generated locally?
uplink revoke --access access_name doesn’t work. Also tried uplink revoke access_name.

The revoking named access grant doesn’t work. You need to put the serialized access grant, stored in your config.yaml with that name.

uplink revoke --access 1Sdkfjoeurotu945ut43759u4r0934utr34t45....
1 Like

Where can I find it?
find / -name config.yml found nothing related to uplink =(

The default location for Linux is ~/.local/share/storj/uplink/config.yaml

I added a task to the backlog to add this information to the documentation.

1 Like

Ah I was searching for .yml file. Sorry for inattention.

What does it ask for now?

upd. tried calling uplink revoke access_grant without --access flag, getting this error now:

Error: uplink: permission denied (metaclient: Unauthorized API credentials)

I believe that’s because I’ve generated another access grant?

This is because you either revoked it or deleted in the Satellite UI.
You can revoke the access grant in a serialized form with or without --access flag.

The inability to revoke a named access grant I believe is a bug and I submitted an internal issue a while ago. This bug is solved in [Tech Preview] Uplinkng (new enhanced uplink cli)

1 Like

I needed to delete accesses.test from config.yaml to remove the grant from the list.
Thank you for the help, Alexey.

Oh, and @Alexey could you please clarify the usage of --access flag? I thought it’s used to access a grant by name.

1 Like

You can use the Access Flag to track whether a region covered by the translation table entry has been accessed.

Hello @jalbert48 ,
I think you confused discussed question with IP tables. These are different topics.

If you have a question - please, create an own topic.

Ok, Thanks for your response @Alexey