Changelog v0.29.3

Satellite migration to cockroach
Next week we are going to migrate the satellite databases to cockroach one by one. You will notice order sender errors and checkin errors doing the downtime. Keep an eye on the announcement channel.

Let us know if you want to help us testing everything. Storj-sim is able to connect to a cockroach cluster.

For Storage Node Operators

WebUI Notifications
Some of you might notice the new notification section on the storage node webUI (refresh CRTL + F5). At the moment nothing can trigger a notification.

Graceful Exit
Graceful exit is finally available. Careful there are a few traps and requirements. Before you call it please read this carefully: Graceful Exit Guide

Garbage collection
The satellite was missing a timeout on sending out the bloomfilters. As a result some satellites never finished the first garbage collection run. You might notice additional garbage collection activity with this release.

For Endusers

Performance improvements on delete
To delete a segment the uplink had to contact up to 80 storage nodes. We moved this communication from the uplink to the satellite. Now the uplink only has to delete the segment from the satellite and the satellite will send delete messages to the 80 storage nodes in the background.

Delete files without encryption key
Losing the encryption key also means losing access to all corresponding files because even the file path is encrypted. We have implemented a solution to that problem. uplink ls sj://bucket --encrypted will print out the encrypted path and that can be used for uplink rm sj://bucket/... --encrypted.


I think the red dot should only be shown if there are any unread notifications and removed when all notifications are read or marked as read.


I can see already SNOs who will use this method for various of reason creating threads here when it fails… :smiley:


How about update public road map? I think we are stuck on the past year :smiley:

1 Like

Yeah, they don’t update it anymore, and when they do, it’s usually behind.

11 posts were split to a new topic: Windows GUI doesn’t updated

They updated it today I believe:

Yeah, and it’s already 2 versions behind on the day they updated it. xD

sorry about that! just updated @Odmin


Thanks a lot!
Please don’t worry, I know, it was a busy time before the new year.

1 Like

Hello all, 2 of 3 nodes aren’t updated: 2 nodes Win Pro/ Docker still Node Version: v0.28.4 but third one Ubuntu Linux/Docker already updated to Node Version: v0.29.3 , is that ok?

You might want to check the logs of watchtower.

Could you please advise right command to see watchtower logs? I am not able to find something working…

Windows docker

docker logs --tail 20 watchtower

any return from this, just empty line

Did you setup watchtower?

yes, I had no problem before, till this release I started node on alpha… I tried to set watchtower again , but docker told me it’s already running…

Did you update your watchtower since alpha?

No, didn’t know that’s needed,
I just tried to remove container now and set again, but nothing changed.