Docker repository for Ubuntu 20.04 LTS not available?

Being new to both Linux and Storj, and after having several issues with a Windows based storage node, I have started building a Linux Ubuntu node, installing the latest version of Ubuntu. I have just started the docker engine installation part of the process and I have come up with a bit of a issue. On the part of adding the repository for my version of Ubuntu, I realise that because the version I am using, the version of Docker I want is not available. I am guessing this is because this release of Ubuntu only came out last month?

Does any one have a solution on how I can rectify this issue? Can I install a different version of Docker or do I have to install a older version of Ubuntu? If I have to install a older version of Ubuntu, I am guessing that would mean moving all the keys over, of which I have not the experience with Linux yet to do that.

edited because im not sure that docker community version is ok

Apologies for the odd question but what do you mean by your comment? :slight_smile:

I edited my post because i had posted the following link. I will share it anyways but you should wait till another storj user confirms if it is ok.

1 Like

Docker CE is fine. I use Docker CE to run many Storj nodes, and our company uses Docker CE in production on our servers for various web applications.


Do you have a guide / link to Docker CE I can read up on? As mentioned above, I am very new to Docker (first week of using it) and relatively new to Ubuntu / Storj

Thanks for your help. :slight_smile:

@JoshGarza, thanks. I missed your reply as it didn’t show up initially for me.

Thanks for your help.

1 Like

The Docker documentation is a great resource to learn what Docker is and how to use it.

1 Like

In case it’s helpful, my node is Ubuntu 20.04 and docker --version shows:
Docker version 19.03.8, build afacb8b7f0

A quick update…

SO I went for it and used the Docker Engine bionic (Ubuntu 18.04 LTS) release file on my Ubuntu 20.04 LTS focal. So far, so good but having another issue now. I have made it all the way to the point in the CLI setup of ‘Check the status of your node’ with what I feel is success so far but I am unable to check the status of my node through any of the means provided. I dont think it is related, unless anyone thinks different?

Thank you to @JoshGarza and everyone else for your help.

I’ll post a final update on how it goes with my current issue and if this solution works.

1 Like

Show us the docker command you used to start your node (or the docker-compose.yml file if you started it that way). Also the output of docker ps would be helpful.

Something doesn’t feel correct here.

You should not use the device directly. You should mount it first:


@Alexey, I followed the Storj instructions for mounting the drive. Is the location incorrect in the above?

/dev/sdb is the actual hard disk as a device. You’ll need to partition it (which would create partition devices like /dev/sdb1), format the partition, and then mount that partition in /etc/fstab to something like /mnt/storj. Then you’d use /mnt/storj in place of /dev/sdb in your docker run command.


So another update to my installation. Its still not working. I have updated the destination location and then it said online for about a hour. It then said offline, I went to check again and now I have the following message 'Error response from daemon: Container (hidden information) is not running. The CLI dashboard doesn’t work now, and the Storage Node Operator Web Dashboard has never worked, on any computer. Any help would be appreciated.

sudo docker run -d --restart unless-stopped --stop-timeout 300
-p 28967:28967
-e WALLET=(hidden info)
-e EMAIL=(hidden info)
-e ADDRESS=(hidden info)
-e STORAGE=“2.55TB”
–mount type=bind,source=/home/jason/backup/storagenode,destination=/app/identity
–mount type=bind,source=/mnt/storj01,destination=/app/config
–name storagenode storjlabs/storagenode:beta

additional info

Restart your node and copy here the output of this command:

sudo docker logs storagenode

This says that the dashboard will only work on the local computer. It will also only work when the container is running i.e. in docker ps the status needs to be “up”

You can tidy up your old hello-worlds with e.g. “docker rm 12345”