Error 1067: the process terminated unexpectedly

Now that I read that article again, I might know why I had that problem.
After I installed the docker, an update for the docker was available, so I installed it.
And right after the update, that problem occured.
Seems that this would be the solution?

“It’s also important to not stop the Storj docker from the ui, but instead type docker stop -t 300 storagenode in the terminal. If using an autoupdater, make sure to also set its timeout to 300 before stopping.”

How do I change this timeout?

Ok. Thank you.
Then I give unraid a chance with that new timeout.

hola me esta ocurriendo este error, he seguido los pasos del foro y el programa sigue sin funcionar bien

Hola @Cristian,
Bienvenido al foro!

Por favor, publique las últimas 20 líneas de su registro:

4 posts were split to a new topic: “error”: “trust: malformed cache: invalid character

A post was split to a new topic: Error creating tables for master database on storagenode: migrate: no such table: satellites

Lately I also have this error, probably because of a few unexpected power outages.

Hi @bbvedf
Your bandwidth.db file appears to be corrupt or an incorrect schema compared to the storagenode version. The previous fix from @Alexey was here:

1 Like

Done, but error persists.
Just repair only bandwith.db?


That was the only one mentioned in the error. Is the log error now different or mentioning a different database?

edit - it’s also possible the schema has changed so the rebuild commands would be different now.

1 Like

I have checked all the db files. This is the only one that has errors. Can the problem be there? Can be solved?

C:\Users\bbvedf\Downloads\sqlite-tools-win32-x86-3380000>sqlite3 f:\storage_usage.db "PRAGMA integrity_check;"
*** in database main ***
On tree page 167 cell 37: Rowid 116129 out of order
On tree page 167 cell 36: Rowid 116130 out of order
On tree page 167 cell 35: Rowid 116130 out of order
On tree page 167 cell 34: Rowid 116130 out of order
On tree page 167 cell 33: Rowid 116131 out of order

What does the storagenode log file show?

You could take a backup, recreate all the db’s, then copy back the working ones -

1 Like

If it’s not the same, it looks a lot like…

Yeah, so looks like @Alexey’s command is for an older version. You could try the link above for “How to fix database…”

1 Like

I just checked. The schema in the linked post still matches the latest version as far as I can tell.

CREATE TABLE bandwidth_usage (
                                                satellite_id  BLOB    NOT NULL,
                                                action        INTEGER NOT NULL,
                                                amount        BIGINT  NOT NULL,
                                                created_at    TIMESTAMP NOT NULL
CREATE TABLE bandwidth_usage_rollups (
                                                                                interval_start  TIMESTAMP NOT NULL,
                                                                                satellite_id    BLOB    NOT NULL,
                                                                                action          INTEGER NOT NULL,
                                                                                amount          BIGINT  NOT NULL,
                                                                                PRIMARY KEY ( interval_start, satellite_id, action )
CREATE INDEX idx_bandwidth_usage_satellite ON bandwidth_usage(satellite_id);
CREATE INDEX idx_bandwidth_usage_created   ON bandwidth_usage(created_at);

@bbvedf Just in case something went wrong in the process. I created an empty db file for you with the right schema. Stop your node, rename the old bandwidth.db to something else as a backup and replace it with this one. rename the new one to bandwidth.db.

The node should now start again, but you will lose historic bandwidth stats. (This has already happened if you tried to recreate the db with those instructions anyway)


Thanks guys,
I have already managed to get it to start and stay stable with the “How to fix …” guide

I have made a copy of all the db files.

Then I have deleted all of them and started the service. This has created new db’s.

Then I have been stopping / copying / starting my backup db. I think I have only two bad: bandwidth and storage_usage.

So with those two files being new, the others being backups, … I don’t see very dramatic damage.

I have seen another very strange thing (perhaps again due to power outages?) and that is that the yaml file had changed.
Specifically the ‘storage.allocated-disk-space’ line. I don’t know if any other.

Node was messed up :frowning:

With a docker setup the config file doesn’t store any of the settings you pass through the docker run command. So it probably already was that way. The node uses the settings from the run command with precedence over the config.yaml file.


2 posts were merged into an existing topic: Error: trust: malformed cache: unexpected end of JSON input

3 posts were merged into an existing topic: FATAL Unrecoverable error {“error”: “trust: malformed cache: invalid character ‘\x00’ looking for beginning of value”