Error: CA certificate and/or key already exists, NOT overwriting!

Hi I am trying to set up a 2nd node on my machine (windows 10) but am not sure how to generate a new identity without the below error appearing. Can anyone advise?

Error: CA certificate and/or key already exists, NOT overwriting!

You need to create a new identity from scratch including requesting a new identity key. I don’t use Windows but somehow you’ll need to be able to run the identities side-by-side as a single identity is associated with a single node.

You can create identity on another computer and copy it to this computer to run multiple nodes

1 Like

If you dont just simply delete the old identity you had, You can just run ./identity.exe create storagenode2 it will create a new folder just for this node and then you will need to authorize it the same way
./identity.exe authorize storagenode2 <email:characterstring>

3 Likes

I knew it was something simple like this lol thank you!

I’m installing a node on a Linux computer for the first time and got this error???
aurum@Rig-27:~ unzip -o identity_linux_amd64.zip Archive: identity_linux_amd64.zip inflating: identity aurum@Rig-27:~ chmod +x identity
aurum@Rig-27:~ sudo mv identity /usr/local/bin/identity aurum@Rig-27:~ identity create storagenode
Error: CA certificate and/or key already exists, NOT overwriting!

I have no idea why or how to fix it.

aurum@Rig-27:/usr/local/bin$ ls -l
total 18452
-rwxr-xr-x 1 root root 6946 Aug 5 2019 apt
-rwxr-xr-x 1 root root 535 May 26 06:31 gnome-help
-rwxr-xr-x 1 root root 196 Feb 7 2019 highlight-mint
-rwxr-xr-x 1 aurum aurum 18864608 May 20 03:45 identity
-rwxr-xr-x 1 root root 243 Aug 30 2017 mint-sha256sum
-rwxr-xr-x 1 root root 964 May 15 2019 search
-rwxr-xr-x 1 root root 552 May 26 06:31 yelp

Edit: Scanned back through the command line history and see that I entered a single command, many commands ago:
aurum@Rig-27: ./identity_linux_amd64 create storagenode
Which makes no sense for two reasons: 1, I’ve successfully installed 7 nodes on 7 computers and 2, Rig-27 has a teeny tiny puny little 500 GB NVMe SSD that is not eligible to host a node. This time I’m trying to figure out how to attach three 3 TB HDDs and put nodes on them. I guess I need to delete the identity on this puny little bitty 500 GB SSD, mount the first 3 TB HDD and try again. Advice is welcome as I cannot find the instructions for my desired configuration. It’s surprising that a procedure for this is not included in the installation guide.

The identity binary creates identity with the specified name in the ~/.local/share/storj/identity folder.

ls -l ~/.local/share/storj/identity

If you have not moved the previous identity from there, it’s time to do it now.
Or you can use a different name not the storagenode

I’m now running identity for the third time. All 3 times
grep -c BEGIN ~/.local/share/storj/identity/storagenode1/ca.cert
grep -c BEGIN ~/.local/share/storj/identity/storagenode1/identity.cert
return ed 1 & 2 in stead of 2 & 3. The guide only says try again if it’s not 2 & 3.

And when I try to update my repositories I get:
Err:6 https://download.docker.com/linux/ubuntu bionic InRelease
The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 7EA0A9C3F273FCD8
Reading package lists… Done
W: GPG error: https://download.docker.com/linux/ubuntu bionic InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 7EA0A9C3F273FCD8
E: The repository ‘https://download.docker.com/linux/ubuntu bionic InRelease’ is not signed.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.

Did you try to install docker according to this page? https://docs.docker.com/engine/install/ubuntu/

Then you forgot step 2

curl -fsSL https://download.docker.com/linux/ubuntu/gpg | sudo apt-key add -
1 Like

Thanks, that was it for installing docker.
The major problem is why am I getting 1 & 2 instead of 2 & 3 ???

Tried it again and it’s still 1 & 2 instead of 2 & 3.
Surely this isn’t the first time this has happened.
What’s wrong???

It’s not authorized. Follow the instructions to authorize the identity with the token you received in your email.

https://documentation.storj.io/dependencies/identity#authorize-the-identity

Thanks, that fixed it…