Error: open /app/config/config.yaml1654586245: permission denied

So this is the full command :
docker run --rm -e SETUP=“true” --mount type=bind,source=C:\Users\***\AppData\Roaming\Storj\Identity\storagenode,destination=/app/identity --mount type=bind,source=C:\,destination=/app/config --name storagenode storjlabs/storagenode:latest

And get this error :
Error: open /app/config/config.yaml3848382200: permission denied

Big thanks!

That worked.

Although now when I try to run the following command :
docker run -d --restart unless-stopped --stop-timeout 300 -p 28967:28967/tcp -p 28967:28967/udp -p 127.0.0.1:14002:14002 -e WALLET=“0xMYWALLET_ADDRESS” -e EMAIL=“MY_EMAIL_ADDRESS” -e ADDRESS=“MY_PUBLIC_IP_ADDRESS:28967” -e STORAGE=“1TB” --mount type=bind,source=C:\Users\***\AppData\Roaming\Storj\Identity\storagenode,destination=/app/identity --mount type=bind,source=C:\StorjNode01,destination=/app/config --name storagenode storjlabs/storagenode:latest

I receive an access denied status message. Please help.

Dont run docker on windows that is a bad idea…

It works. I have migrated my docker to wsl2 and on version docker-desktop 4.2.0 it’s pretty stable.

1 Like

It’s running, but still showing offline. I have applied all port forwarding settings.

image

In addition please provide the last 10 lines from your logs: How do I check my logs? - Storj Docs

Hi, I also get the same error “Error: open /app/config/config.yaml165682803: permission denied”. What was the fix? I am unable to see any useful replies.

Hello @vnegi10 ,
Welcome to the forum!

Please show your docker run command (you can mask the private info).
Did you run the setup command?

Hi,
did you find a fix for the “Error: open /app/config/config.yaml165682803: permission denied"?

Why I can’t see the replys to this issue? Because I am running on the same issue when setting up a new node

after I am running

docker run --rm -e SETUP=“true” --user $(id -u):$(id -g) --mount type=bind,source=“/home/pi/.local/share/storj/identity/storagenode”,destination=/app/identity --mount type=bind,source=“/mnt/storj-project/”,destination=/app/config --name storagenode storjlabs/storagenode:latest

in the end I am getting this

Running ./storagenode setup --config-dir config --identity-dir identity --metrics.app-suffix=-alpha --metrics.interval=30m --version.server-address=https://version.storj.io --console.address=:14002 --storage.allocated-disk-space=2.0TB
2023-04-27T19:22:27.607Z INFO Anonymized tracing enabled {“Process”: “storagenode”}
Error: open /app/config/config.yaml1751701671: permission denied

I have a 11TB setup

You need to change the owner for the data location to your user and group:

sudo chown $(id -u):$(id -g) -R /mnt/storj-project/

then, perhaps modify the access permissions to allow writes, reads and executions (for dirs).

I think that it worked but now running in a different issues when I am tailing the logs

2023-04-28T12:21:40.649Z INFO Invalid configuration file value for key {“Process”: “storagenode-updater”, “Key”: “log.caller”}
2023-04-28T12:21:40.649Z INFO Invalid configuration file value for key {“Process”: “storagenode-updater”, “Key”: “log.output”}
2023-04-28T12:21:40.649Z INFO Anonymized tracing enabled {“Process”: “storagenode-updater”}
2023-04-28T12:21:40.651Z FATAL Error loading identity. {“Process”: “storagenode-updater”, “error”: “file or directory not found: open identity/identity.cert: not a directory”, “errorVerbose”: “file or directory not found: open identity/identity.cert: not a directory\n\tstorj.io/common/identity.Config.Load:326\n\tmain.cmdRun:108\n\tstorj.io/private/process.cleanup.func1.4:377\n\tstorj.io/private/process.cleanup.func1:395\n\tgithub.com/spf13/cobra.(*Command).execute:852\n\tgithub.com/spf13/cobra.(*Command).ExecuteC:960\n\tgithub.com/spf13/cobra.(*Command).Execute:897\n\tstorj.io/private/process.ExecWithCustomConfigAndLogger:92\n\tmain.main:20\n\truntime.main:250”}
2023-04-28 12:21:40,655 INFO exited: storagenode-updater (exit status 1; not expected)
2023-04-28T12:21:40.739Z INFO Anonymized tracing enabled {“Process”: “storagenode”}
2023-04-28 12:21:40,740 INFO gave up: storagenode-updater entered FATAL state, too many start retries too quickly
2023-04-28T12:21:40.741Z ERROR Failed to load identity. {“Process”: “storagenode”, “error”: “file or directory not found: open identity/identity.cert: not a directory”, “errorVerbose”: “file or directory not found: open identity/identity.cert: not a directory\n\tstorj.io/common/identity.Config.Load:326\n\tmain.cmdRun:182\n\tstorj.io/private/process.cleanup.func1.4:377\n\tstorj.io/private/process.cleanup.func1:395\n\tgithub.com/spf13/cobra.(*Command).execute:852\n\tgithub.com/spf13/cobra.(*Command).ExecuteC:960\n\tgithub.com/spf13/cobra.(*Command).Execute:897\n\tstorj.io/private/process.ExecWithCustomConfigAndLogger:92\n\tmain.main:478\n\truntime.main:250”}
Error: Failed to load identity: file or directory not found: open identity/identity.cert: not a directory
storj.io/common/identity.Config.Load:326
main.cmdRun:182
storj.io/private/process.cleanup.func1.4:377
storj.io/private/process.cleanup.func1:395
github.com/spf13/cobra.(*Command).execute:852
github.com/spf13/cobra.(*Command).ExecuteC:960
github.com/spf13/cobra.(*Command).Execute:897
storj.io/private/process.ExecWithCustomConfigAndLogger:92
main.main:478
runtime.main:250
2023-04-28 12:21:40,742 WARN received SIGQUIT indicating exit request
2023-04-28 12:21:40,742 INFO waiting for storagenode, processes-exit-eventlistener to die
2023-04-28 12:21:40,745 INFO exited: storagenode (exit status 1; not expected)
2023-04-28 12:21:41,748 INFO stopped: processes-exit-eventlistener (terminated by SIGTERM)

My identity.cert is there

This my identity folder

~/.local/share/storj/identity/storagenode $ ls -l
total 24
-rw-r–r-- 1 pi pi 558 Apr 27 19:10 ca.1682619013.cert
-rw-r–r-- 1 pi pi 1088 Apr 27 19:10 ca.cert
-rw------- 1 pi pi 241 Apr 27 01:45 ca.key
-rw-r–r-- 1 pi pi 1096 Apr 27 19:10 identity.1682619013.cert
-rw-r–r-- 1 pi pi 1626 Apr 27 19:10 identity.cert
-rw------- 1 pi pi 241 Apr 27 01:45 identity.key

problem solved. I had found the issue

Can you share what was the issue? Could help others in the future.

Did you? :slight_smile: I seem to be having the same issue

If you use a Docker Desktop, then owner rights and full read-write-delete-execute permissions for your data location and identity should be granted to your user who running the Docker Desktop.
You may also revoke Creator-Owner grants to prevent an accidentally changing of these permissions and/or the owner in future.

If you use Linux, then

Hello Alexey - always fast with great comments. I’ll try it out when I get home, and get back to you. Kind regards friend.

1 Like