Failed to dial storage node

My log is giving me “ping satellite error: failed to dial storage node”. Any suggestions/fixes to remedy the issue? Thank you in advance for any guidance!

Your node is offline because your external address is not reachable.
Please, use this checklist to troubleshoot the offline issue:

Thank you for the list. The IP listed on does not match the router IP. However, I did use NoIP DUC. I have completely turned off Windows Firewall. So maybe I am thinking there could be an issue with the port forwarding that I set up in the router? (attached screenshot of forwarding setup in router)


Any chance that connecting via VPN could be causing issues? I’ve followed the guide on firewall, and just still not seeing that the port 28967 is “open” status.

The NoIP doesn’t help, if your WAN IP doesn’t match your public IP.
If you want to use VPN, you should use VPN with port forwarding option such as, ngrok, PIA, AirVPN, PureVPN, etc.
Each of them offer a different method to forward the port, some of them offer a hostname, thus you would not need a NoIP.

Well noted! Uninstalled NoIP. Will start from beginning of Checklist. Currently using ExpressVPN

@Alexey Okay - I have confirmed now that IP address matches the DNS IP Address. Node showing Offline.

You need to check the WAN IP on your router, not DNS IP Address. The WAN IP must match the public IP, this is the only way to make port forwarding work.
If they do not match, then you have a few options:

  • call to your ISP and ask them to give you a public IP, it could be dynamic, but must be a public (WAN IP matches IP on yougetsignal); you can say to their support that you want to have an access to your security IP cam, with this you would not need to explain Storj;
  • switch the ISP to one, who offer a public IP;
  • use VPN with port forwarding option (the ExpressVPN do not offer it except flashing firmware to your hardware router).