Failure setting up second node on the same LAN. Port Forwarding issue?

I’m trying to set up a second node using a second computer. First node is almost a year old and fully vetted. Both nodes are connected via LAN cables to the same router.

Since my original node is using port forwarding “28967” I selected “28970” for the new node. I set up port forwarding using my deco router app for the new node. I select “28970” for external port but set the internal port to “28967”. I also set the protocol to TCP

In my confirm.yaml file I have the following…

the public address of the node, useful for nodes behind NAT

contact.external-address: :28970

public address to listen on

server.address: :28967

Also, I made sure the user email and payout wallet address are the same as my first node.

My new node says offline but is counting the uptime (basically the time since I lasted restarted my PC) Interestingly, it says “LAST CONTACT 17716100h 41m ago”

Any ideas what I might be doing wrong?

confirm.yaml or config.yaml?

could you pls share your run command?

If I understand correctly you forwarded the external port 28970 to the internal 28967 on your router ? If that’s the case you should change it to be 28970 on both sides.
As @Bivvo sait you can include your config.yaml that’ll help us, just make sure to remove all information you want to keep private (ex IP address).

config.yaml is the file I was referring too. confirm was a typo.

On my router I have the “external Port” set to “28970” if I try to set it to “28967” my routher app says: “this port is already taken. Please select another”

also on my router I have “internal port” set to “28967” but if I erase it and leave it blank it still doesn’t work. so I will leave it blank for now.

Here is what is in the config.yaml that I imagine is relevant…

the public address of the node, useful for nodes behind NAT

contact.external-address: redacted ip :28970

public address to listen on

server.address: :28967

private address to listen on


I don’t know what you mean by “run command”. I am using windows. The node automatically runs on start up.

Hi, on your router you have to set internal and external ports to 28970.
I’ve never ran a storagenode on windows so I can’t really help you with the rest but I’d suggest to create a new storagenode specifying port 28970 everywhere it asks and not messing with config.yaml

the public address of the node, useful for nodes behind NAT

contact.external-address: :28970

public address to listen on

server.address: :28967 - - - this one shold be same as External contact addres port.

**Also if your nodes are on same PC, you need to have **
this one unic on each Windows PC

private address to listen on


All this setup on config file, and then make restart to node.

1 Like

Thanks for tuning in @Vadim, if someone knows his way around running nodes on windows it’s you :upside_down_face:

none of those things fixed the issue. I set both the “internal port” & “external port” on my router to 28970.

I also changed the config.yaml file to the settings @Vadim suggested.

Restarted the computer and still not luck.

I also ran the commands below in powershell as an administrator:

New-NetFirewallRule -DisplayName “Storj v3 TCP” -Direction Inbound –Protocol TCP –LocalPort 28970 -Action allow
New-NetFirewallRule -DisplayName “Storj v3 UDP” -Direction Inbound –Protocol UDP –LocalPort 28970 -Action allow

And still the node says offline.

My nodes are not on the same pc. Two seperate PC’s. One node is almost a year old and is running find (the node using port 28967) and the other node I am trying to set up. The two PC’s are connected to the same router though…

Any other ideas? @Alexey can you help at all?

Have you checked if your ports are in fact open e.g. with ?

Just to be completely sure, can you confirm you did set it up like so:

internal port in config.yaml
MyPC1: server.address: :28967
MyPC2: server.address: :28967

external port in config.yaml
MyPC1: contact.external-address:
MyPC2: contact.external-address:

port forwarding in router
external port 28967 → MyPC1:28967
external port 28968 → MyPC2:28967

local Firewall
MyPC1: allow incoming TCP/UDP on port 28697
MyPC2: allow incoming TCP/UDP on port 28697

If it’s all configured like this, it should just work - if not, I highly suspect there’s something wrong with port forwarding in your scenario. Would you share a screenshot of your router’s port forwarding page?


This is contradictive as Vadim suggested setting port 28967 in your config.yaml, so redirecting to port 28970 will not work.

If you want to use port 28970 both externally and internally, you will have to tell the node via the following lines in your config.yaml:
server.address: :28970

When I go to that website it displays and IP address that does not match the computer’s IP address that my router app has listed.’s listed IP address also does not match the IP address I get when I run “get-netipaddress” in powershell.

If I manually type in the correct IP address (according to my Deco Router App and “get-netipaddress”) into and input the port number 28970 than it says the port is closed.

I have all the settings as you suggested. I don’t see why 28968 is any better than 28970 but I made the changes per your suggestion.

I’m using NO-IP (DUC V4.1.1), could have have anything to do with it?

On the “NO-IP” website dashboard I have two “hostnames” set up. 1 using for MYPC2 which is the one I can’t get to work and then another host name using for MYPC1 which is the node I have up and working correctly. in both cases the “” that you have written above is correctly replaced with the host name addresses in the respective config.yaml files.

However, BOTH hostname address on my NO-IP dashboard have the same IP address listed. This is the same IP address that shows up when I go to

I just realised that I was wrong, @twl is right on how you should forward the ports I didn’t catch that you were running the nodes on different computers…
Sorry for the headache

1 Like

I appreciate you trying to help all the same

1 Like

For anyone that still has the patience to keep helping me this is a screen shot of the stuff in my config.yaml file:

And these are the settings in the Port Forwarding Tab in my Deco Router App. These are the ONLY settings I can change under port forwarding and besides the IP address I’ve typed it here exactly as it appears in the app.

Service Type = DNS
Service Name = Mystorj
External Port = 28970
Internal IP = (redacted but it matches the computer I’m trying to start the node on)
Internal Port (Optional) = 28970
Protocol: TCP

It’s not better from a technical standpoint, it’s just easier to memorize since it is more logical. More logical/obvious → lower probability of typing errors etc :wink:

Because this website only knows your router’s external IP address, not your PC’s. Actually, you should enter your DDNS address there.

This again is because retrieves your router’s external IP while get-netipaddress displays the local addresses of your PC’s network interfaces.

You should not use a DUC software but instead use the DDNS settings of your router. Enter your No-IP credentials there.

You only need only 1 hostname (for your router). The router then forwards to ether of your PCs based on the port that is knocked at from the outside, like what I posted yesterday.

Because they share the same external IP address (the one your router got from your ISP). Again, this is working as intended. That is why you need to specify different ports.

Now you are using port 28970 again?

I think that should rather say “custom” instead of “DNS”, but shouldn’t matter here.

There is no need to censor your internal IP addresses :wink:

Please, first set up DDNS in your router, then remove the DUC software from your PCs, then check the instructions I posted yesterday again real thoroughly.
/Edit: actually, first remove the DUC software from your PCs, then configure DDNS in your router.

Can you show picture how you made port forwarding in your router?

God must not want this node to be set up.

I uninstalled DUC as you suggested and then set up DDNS. I then powered off my router and cable modem for 1 minute before powering back on.

Next I made the changes as you suggested.

Still not luck. This is where we are at:

Service Type = DNS
Service Name = Mystorj
External Port = 28970
Internal IP = (I believe you that I don’t need to redact it but I’m doing so anyway out of an abundance of caution)
Internal Port (Optional) = 28967
Protocol: TCP