Give Feedback, Get Paid

I just got a mail (I believe originating from

Just want to confirm if this is to be trusted.

@jocelyn Do you recognize this? before people sign up to things that might be wrong.



I got the same email, so my guess is it’s real. But confirmation is always nice.

I tried it doesn’t seem to work correctly with the app cant sign in.

yeah… would like to hear from a official member regarding the legitimacy of this mail.

Not going to give some random site my information without knowing the purpose.

I got the e-mail as well. I signed up…

1 Like

Im pretty sure its legit… less someone has access to all our emails and went out of there way to scam everyone…with a legit program for testing. seems kinda weird and yet it doesnt ask for alot of personal information so I wouldn’t worry about that.

Hey everyone, This is a legit email! The product team at Storj Labs would like to do more usability testing with our community and our Node operators before we build out some of the features we have on our roadmap to make sure those features are truly solving pain points. If you have any questions please let me know! if you want to participate or are interested the link in the email will lead you to which is how we are conducting these usability tests and focus group sessions.


Cool :slight_smile:

I hope tests can be done directly on their website though… Because although it accepts my password on the web interface, their application keeps telling me my password is wrong…

We’re off to a good start… :sweat_smile:

Hey @Pac if you are having problems signing into user after you created an account can you try resetting your password on their site? unfortunately, there isn’t anything we can do to resolve this because we don’t control or manager

I also couldnt sign into the app and I tried to reset password still nothing.
Edit: Nevermind it works now.

Same here :confused:

lol same here too… can’t login anymore.

oh wait, it works. stupid me. used my password manager and it tried to log in with the username but you have to use your email to log in…

it seems to work for me now.
But I don’t think we are stupid. I am 100% sure I already tried 1 or 2 hours ago and it didn’t work (I tried with my email and my username ; I was sure about my password).

We are now all waiting for available tests :slight_smile:

okay. then i might sign up.

Thanks for clarifying

Hey @brandon , I did reset my password already on their site and I can correctly sign in on their web interface.

But the change doesn’t reflect immediately to their mobile app it seems, or something’s simply off with the way their system works…

Because as @jeremyfritzen and probably others, I don’t think I’m mad: I did try several times with the correct password, and tried resetting the password… and at some point I had to create an account with a nickname (not an email address), with password rules not exactly the same…

In short, their UX is confusing.
But it works now, so there must be some caching issues on their side…

But anyway, yeah: now waiting for available tests ^^

1 Like

Hi Brandon,

When asked for what devices I have available I noticed Linux was not on the list. Is that intentional?



I wondered the same thing, seems quite weird since many SNOs run some kind of linux distribution.


Yeah and raspberrys or other SBC are not listed.

1 Like