HELP i cant get my node online - ERROR contact:service ping satellite failed

i installed a new storage node but i cant get it online.

ERROR contact:service ping satellite failed {“Satellite ID”: “12L9ZFwhzVpuEKMUNUqkaTLGzwY9G24tbiigLiXpmZWKwmcNDDs”, “attempts”: 1, “error”: "ping satellite

i have checked my identity and become normal output 1 and 2.

i made port forwarding rule on my router, TCP port 28967 to my PC with storagenode.

i set up an firewall inbound rule to allow any traffic from any source and TCP 28967.

i checked my external address on https://www.yougetsignal.com/tools/open-ports/ matches the WAN IP on my router and port is open.

i use NoIP, and application called DUC to update my ddns and this is also ok.

I tryed alot but without success and rly need some help to geth this working.

*changed ddns in log bcs i am new user and cant post links in forum :frowning:

Did you run the setup first with the identity file?

   docker run --rm -e SETUP="true" \
    --mount type=bind,source="<identity-dir>",destination=/app/identity \
    --mount type=bind,source="<storage-dir>",destination=/app/config \
    --name storagenode storjlabs/storagenode:latest

Hello @cryptomaxx,
Welcome to the forum!

It should be 2 and 3. So, your identity doesn’t signed. Please, sign it with a new authorization token.

my node runs on windows 10 maschine not in docker and i instaled it with GUI Install for windows.

i dont know what you mean.

sry it is 2 and 3 my bad…

start looks normal:

2021-02-06T15:43:19.393+0100 INFO Configuration loaded {“Location”: “C:\Program Files\Storj\Storage Node\config.yaml”}
2021-02-06T15:43:19.468+0100 INFO Operator email {“Address”: “xxxx”}
2021-02-06T15:43:19.468+0100 INFO Operator wallet {“Address”: “dummy :)”}
2021-02-06T15:43:20.115+0100 INFO Telemetry enabled {“instance ID”: “xxxx”}
2021-02-06T15:43:20.153+0100 INFO db.migration Database Version {“version”: 48}
2021-02-06T15:43:21.549+0100 INFO preflight:localtime start checking local system clock with trusted satellites’ system clock.
2021-02-06T15:43:22.466+0100 INFO preflight:localtime local system clock is in sync with trusted satellites’ system clock.
2021-02-06T15:43:22.467+0100 INFO trust Scheduling next refresh {“after”: “4h52m53.410934749s”}
2021-02-06T15:43:22.467+0100 INFO bandwidth Performing bandwidth usage rollups
2021-02-06T15:43:22.467+0100 INFO Node xxxx started
2021-02-06T15:43:22.467+0100 INFO Public server started on [::]:28967
2021-02-06T15:43:22.467+0100 INFO Private server started on 127.0.0.1:7778

I would suggest to remove your personal info

ok thx is it ok like this

You still shows your wallet :slight_smile:

Please, check that

nslookup your.ddns.org 8.8.8.8

will return the same IP as your WAN IP and as IP on yougetsignal.

Server: dns.google
Address: 8.8.8.8

*** your.ddns.org wurde von dns.google nicht gefunden: Server failed.

So, your DDNS address is not recognized by the internet. Please, check its spelling.
Ha!
Your DDNS address returns a private address (192.168.x.x) instead of global.
Do you have two routers?

i have a router hang on a provider modem.
and what do you mean check spelling? what?

Seems this provider’s modem have a NAT. In this case you need to create a port forwarding rule on the modem to forward 28967 to the IP of your router. And rule on your router to forward 28967 to the IP of your PC with storagenode.

The other way is to switch the modem to the bridge mode, if possible.

like a error in one symbol in address. Because

meaning that the address is not existing. You need to place your DDNS address instead of your.ddns.org
But I already checked that, and it returns a private address 192.168.x.x instead of your public IP.

hmm i am not so good but i try to port forward in modem.
but by other aplications works port forwarding normal just in my router i dont have to port fw in modem. is it by storj node not the same?

No, but if your DDNS address is updated to the private address, it could mean that you have a double NAT.

86.74.25.111 -> Modem (192.168.1.1) -> (192.168.1.11) Router (192.168.0.1) -> (192.168.0.2) PC with node

Please, try to update the address in the DUC application or remove it and configure the update of the DDNS address on your router (it could be in DDNS section).

Are you actually sure that the WAN address on your router is not private (like 192.168.x.x)?

hmm and how to get in to my modem? do i have to conect it direct to my pc and try to setup the port fw or i can do it ower the router somehow?

If your modem have a NAT, then you can configure it via address of the modem, 192.168.1.1 in this case.
To access it, you should connect to the modem directly and use the http://192.168.1.1 address (or what address it has).

Another option would be to disable NAT on your router, then all port forwarding stuff will be done on modem only.

However, before you consider to do anything - please, confirm first that your router actually have a private IP as a WAN IP.

oh bro thank you so much but i am online now without port fw of my modem.
it was my bad. i head a wrong key from my first install copied into identify folder.
i am so sorry to waste your time.
thank you so much @Alexey

1 Like

You are welcome!
And also you now uses a public IP instead of DDNS.
I hope it’s not dynamic :smiley:

So, there was at least two errors - the DUC updated your DDNS to the private address and also key was wrong.

i hope also but if it is a dynamic i can just change it to my ddns i think :slight_smile: