Help with restarting a node after re-installing Ubuntu

I followed the guides and can’t get my storage node to work.

@Alexey always steps in to help but someone should work on your guides.

I had to re-install my operating system.

My node’s Identity, orders, and data are all on a separate drive.
So I just unplugged the drive from the sata port and re-installed ubuntu and plugged it back in.

Now I am trying to get my node back up and running

According to this guide here

I should run this command in terminal
mkdir -p /mnt/storj/storagenode/storage

Then I should follow this static mount guide

Then I head over to this guide here EXCEPT I skip step 2 as my node is already established

After successfully installing the docker I ran the exact same command I was running before I re-installed Ubuntu and I get this error:

I know the solution is as simple as changing a path. I just don’t know what to change to the path too. @Alexey pointed this out to me in a previous post but I figured the guide would be updated by now and I could just follow it.

Here is a screen shot where everything is at after the static mount:

The error message is quite self explanatory. Your identity path is /mnt/storj/storagenode/storage/storagenode/identity while your command shows /mnt/STORJ/storagenode/identity/storjidentity

Check your paths.

You created /mnt/storj/storagenode/storage, and seems moved your data (blobs, trash, databases) to that folder, but run your docker with path /mnt/STORJ/storagenode/data instead of /mnt/storj/storagenode for some reason.
And your data folder is actually /mnt/storj/storagenode/storage/storagenode/data, not even /mnt/STORJ/storagenode/data (Linux is case sensitive STORJ != storj)

If you want to use /mnt/storj/storagenode/data, then you need to move folder storage with data to there:

mkdir /mnt/storj/storagenode/data
mv /mnt/storj/storagenode/storage /mnt/storj/storagenode/data/

Then move data, identity and orders to the right location:

mv /mnt/storj/storagenode/data/storage/storagenode /mnt/storj/

if you want to move everything to /mnt/storj/storagenode/, then you need to move all folders from /mnt/storj/storagenode/storage/storagenode to /mnt/storj/storagenode/ folder:

mv /mnt/storj/storagenode/storage/storagenode /mnt/storj/

and then move the content of the folder /mnt/storj/storagenode/data/ to /mnt/storj/storagenode/:

mv -r /mnt/storj/storagenode/data/* /mnt/storj/storagenode/


Well I fixed the path error and got what looks like a crypto address when running my docker but the dashboard will not load.

This is the log file

Error: trust: open config/trust-cache.json: permission denied
2022-12-10 03:01:37,773 INFO exited: storagenode (exit status 1; not expected)
2022-12-10 03:01:40,778 INFO spawned: 'storagenode' with pid 87
2022-12-10T03:01:40.804Z	INFO	Configuration loaded	{"Process": "storagenode", "Location": "/app/config/config.yaml"}
2022-12-10T03:01:40.805Z	INFO	Anonymized tracing enabled	{"Process": "storagenode"}
2022-12-10T03:01:40.805Z	INFO	Operator email	{"Process": "storagenode", "Address": "REDACTED"}
2022-12-10T03:01:40.805Z	INFO	Operator wallet	{"Process": "storagenode", "Address": "REDACTED"}
Error: trust: open config/trust-cache.json: permission denied
2022-12-10 03:01:40,861 INFO exited: storagenode (exit status 1; not expected)

NEVERMIND! I got it. it was the same error I was getting before. I went back and looked at an old post you and peer helped me on.

As always thank you again.

1 Like