How do I view node outside of network

So I have been away a couple of days, and I would like to be able to see how my node is doing from another location other than the monitor in my basement attached to my node. I CANNOT even access locally using:
http://MY-IP-ADDRESS:28967

app.storj.io is the login page to our deprecated V2 network customer accounts. This is completely unrelated to remotely viewing your dashboard. I am not even sure where you found a link to that website.

1 Like

Ok thanks, is it possible to access my node dashboard from the web on V3?

I tried:
http://MY-IP-ADDRESS:28967
And it is not working…

Setup a VPN on your router, if it supports it and connect from outside to it.

The thing is, it is not working over my local ip either… Don’t know if it makes any difference, but I have a GUI install.

I have looked at every other post on Web dashboards, and nothing works for me… Does anybody else have any suggestions???

Post your docker run command and remove any personal info from it like your email/eth address

The dasboard port is 14002 not 28967 (unless you changed it in configuration.yaml)

1 Like

I have A GUI setup so I don’t use docker… Do I have to also port forward 14002? I will try that!

I typically use knockd when running some sort of service I want to connect to via the Internet… but don’t want to open up a visible port for port scanners to attempt to exploit. It can be run on DD-WRT routers

Before I try any of that, I want to be able to access the dashboard over my LAN.

If you can access it via the local machine, but not any other host on your LAN … then you probably started the node using a specific address.

Try:

docker run -d --restart unless-stopped -p 14002:14002 -p 28967:28967 \
     -e WALLET=
     ....
    [your other node specific options]

If you’ve got a 127.0.0.1 in there, that means the port is only open for localhost connections.

@beast I have a GUI install, So I do not have docker on my node.

You should modify the console.address: in the "%ProgramFiles%\Storj\Storage Node\config.yaml", you should uncomment this string and remove the 127.0.0.1
Save the config and restart the storagenode service.

@Alexey, I tried all this, and every time I tried and load the page it would say: this site cant be reached 192.168.0.10 took to long to respond.

ALSO, when I tried some of the variations, my node would say offline and would not work at all…

(hashtag) server address of the api gateway and frontend app
console.address: 192.168.0.10:14002

(hashtag) server address of the api gateway and frontend app
console.address: :14002

(hashtag) server address of the api gateway and frontend app
console.address: 14002 (SERVICE WOULD NOT EVEN START WITH THIS)

Try this and see if it works

Well, Now my node is working with that, But when I use http://192.168.0.10:14002 (the local ip of my node, I still get nothing, same thing with my WAN ip… @Alexey Is that not the right address I should be using to log on over a browser?? And @nerdatwork what address would you normally use to log into your node, Locally.

Access over WAN requires port forwarding through your router. This is not a recommended action as it opens your LAN to attack from port scanners and malware. Is the Web Dashboard now available via other LAN hosts? If so, I recommend leaving it behind your firewall.

If you do forward the Web Dashboard, it is recommended that you at least setup basic authentication. Please remember that any passwords will be sent over the Internet in the clear to your authentication mechanism… unless you deploy TLS using either self-signed certs … not recommended … or DV certs such as available using Let’s Encrypt …

@beast I port forwarded 14002 on my node already, A while ago, once I know my dashboard works though, I will probably go with the method you are suggesting… I still cant see my dashboard over my LAN yet, so i would like to get that working first.