How often is used-space filewalker supposed to run

Does the used-space filewalker run periodically?
Or only once after restart and then neveragain until the next restart (of course provided that run on startup is set to true)

It only runs at startup of the node. Node updates also trigger a restart if you’re using the docker image.


I am not sure if there is an additional trigger when the used-space filewalker does not complete. It looks like that tries to re-run it periodically.

But this also means, that if the used space calculations of other processes are wrong, like we see currently with the trash not updating or for other reasons there is no way to redo the used space calculation other than restarting the node.

It’s run only on start, if not disabled. It shouldn’t be run periodically, because it’s a precaution method to get databases updated if the available storage space is changed externally or due to a bug or a databases corruption/lock.
All operations should update databases on success, like uploads, downloads, deletions or moving to the trash.
So, I think this filewalker should be executed only on start as a fallback to force update databases on case of issues. We should fix an affecting bugs/errors instead.

I see.

But effectively we are running it periodically as we get updates like every 2 weeks.
So this could be as well be a setting.

Can you confirm that it is trying to re-reun the filewalker when it did not complete successfully?
Because I had it in the logs but it did not seem to be a node restart.
I don’t know if I find the logs again, I think I have posted them somewhere here, but it seemed to re-run periodically every ?? hours. Could that be?

Yes of course. However with the current situation with the trash not updating correctly it would help.

Found them here:

It can start a few hours later after restart of the node:

You may disable the lazy mode and restart the node, we have a bug in the lazy trash filewalker - it doesn’t update databases on finish. It’s not causing a big problem, unless your node also reported as full to the satellites because of that.