HTTP source: Get https://tardigrade.io/trusted-satellites: dial tcp: lookup tardigrade.io

Hello, I have restarted my server after an update of the operating system, I have two nodes working, but one has not worked again giving the following error

(I have a windows 10 “server” with 2 linux centos 8.x virtual machines)

[root@storj2 ~]# docker logs -f storagenode
2020-04-15T22:06:34.930Z INFO Configuration loaded from: /app/config/config.yaml
2020-04-15T22:06:35.075Z INFO Operator email: xxxxxxxx@gmail.com
2020-04-15T22:06:35.075Z INFO operator wallet: 0x4xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
2020-04-15T22:06:41.523Z INFO db.migration Database Version {“version”: 33}
2020-04-15T22:06:52.311Z WARN trust Failed to fetch URLs from source; used cache {“source”: “https://tardigrade.io/trusted-satellites”, “error”: “HTTP source: Get https://tardigrade.io/trusted-satellites: dial tcp: lookup tardigrade.io on 200.83.1.5:53: read udp 172.17.0.3:45070->200.83.1.5:53: read: no route to host”, “errorVerbose”: “HTTP source: Get https://tardigrade.io/trusted-satellites: dial tcp: lookup tardigrade.io on 200.83.1.5:53: read udp 172.17.0.3:45070->200.83.1.5:53: read: no route to host\n\tstorj.io/storj/storagenode/trust.(*HTTPSource).FetchEntries:63\n\tstorj.io/storj/storagenode/trust.(*List).fetchEntries:90\n\tstorj.io/storj/storagenode/trust.(*List).FetchURLs:49\n\tstorj.io/storj/storagenode/trust.(*Pool).fetchURLs:240\n\tstorj.io/storj/storagenode/trust.(*Pool).Refresh:177\n\tstorj.io/storj/storagenode.(*Peer).Run:652\n\tmain.cmdRun:209\n\tstorj.io/private/process.cleanup.func1.2:312\n\tstorj.io/private/process.cleanup.func1:330\n\tgithub.com/spf13/cobra.(*Command).execute:840\n\tgithub.com/spf13/cobra.(*Command).ExecuteC:945\n\tgithub.com/spf13/cobra.(*Command).Execute:885\n\tstorj.io/private/process.ExecWithCustomConfig:84\n\tstorj.io/private/process.ExecCustomDebug:66\n\tmain.main:329\n\truntime.main:203”}
2020-04-15T22:06:52.316Z INFO preflight:localtime start checking local system clock with trusted satellites’ system clock.
2020-04-15T22:07:07.319Z ERROR preflight:localtime unable to get satellite system time {“Satellite ID”: “12L9ZFwhzVpuEKMUNUqkaTLGzwY9G24tbiigLiXpmZWKwmcNDDs”, “error”: “rpccompat: dial tcp: lookup europe-west-1.tardigrade.io on 200.83.1.5:53: read udp 172.17.0.3:57760->200.83.1.5:53: read: no route to host”, “errorVerbose”: “rpccompat: dial tcp: lookup europe-west-1.tardigrade.io on 200.83.1.5:53: read udp 172.17.0.3:57760->200.83.1.5:53: read: no route to host\n\tstorj.io/common/rpc.Dialer.dialTransport:261\n\tstorj.io/common/rpc.Dialer.dial:238\n\tstorj.io/common/rpc.Dialer.DialAddressID:157\n\tstorj.io/storj/storagenode/preflight.(*LocalTime).getSatelliteTime:110\n\tstorj.io/storj/storagenode/preflight.(*LocalTime).Check.func1:67\n\tgolang.org/x/sync/errgroup.(*Group).Go.func1:57”}
2020-04-15T22:07:12.317Z ERROR preflight:localtime unable to get satellite system time {“Satellite ID”: “1wFTAgs9DP5RSnCqKV1eLf6N9wtk4EAtmN5DpSxcs8EjT69tGE”, “error”: “rpccompat: context deadline exceeded”, “errorVerbose”: “rpccompat: context deadline exceeded\n\tstorj.io/common/rpc.Dialer.dialTransport:261\n\tstorj.io/common/rpc.Dialer.dial:238\n\tstorj.io/common/rpc.Dialer.DialAddressID:157\n\tstorj.io/storj/storagenode/preflight.(*LocalTime).getSatelliteTime:110\n\tstorj.io/storj/storagenode/preflight.(*LocalTime).Check.func1:67\n\tgolang.org/x/sync/errgroup.(*Group).Go.func1:57”}
2020-04-15T22:07:12.317Z ERROR preflight:localtime unable to get satellite system time {“Satellite ID”: “118UWpMCHzs6CvSgWd9BfFVjw5K9pZbJjkfZJexMtSkmKxvvAW”, “error”: “rpccompat: context deadline exceeded”, “errorVerbose”: “rpccompat: context deadline exceeded\n\tstorj.io/common/rpc.Dialer.dialTransport:261\n\tstorj.io/common/rpc.Dialer.dial:238\n\tstorj.io/common/rpc.Dialer.DialAddressID:157\n\tstorj.io/storj/storagenode/preflight.(*LocalTime).getSatelliteTime:110\n\tstorj.io/storj/storagenode/preflight.(*LocalTime).Check.func1:67\n\tgolang.org/x/sync/errgroup.(*Group).Go.func1:57”}
2020-04-15T22:07:12.317Z ERROR preflight:localtime unable to get satellite system time {“Satellite ID”: “12EayRS2V1kEsWESU9QMRseFhdxYxKicsiFmxrsLZHeLUtdps3S”, “error”: “rpccompat: context deadline exceeded”, “errorVerbose”: “rpccompat: context deadline exceeded\n\tstorj.io/common/rpc.Dialer.dialTransport:261\n\tstorj.io/common/rpc.Dialer.dial:238\n\tstorj.io/common/rpc.Dialer.DialAddressID:157\n\tstorj.io/storj/storagenode/preflight.(*LocalTime).getSatelliteTime:110\n\tstorj.io/storj/storagenode/preflight.(*LocalTime).Check.func1:67\n\tgolang.org/x/sync/errgroup.(*Group).Go.func1:57”}
2020-04-15T22:07:12.317Z ERROR preflight:localtime unable to get satellite system time {“Satellite ID”: “121RTSDpyNZVcEU84Ticf2L1ntiuUimbWgfATz21tuvgk3vzoA6”, “error”: “rpccompat: context deadline exceeded”, “errorVerbose”: “rpccompat: context deadline exceeded\n\tstorj.io/common/rpc.Dialer.dialTransport:261\n\tstorj.io/common/rpc.Dialer.dial:238\n\tstorj.io/common/rpc.Dialer.DialAddressID:157\n\tstorj.io/storj/storagenode/preflight.(*LocalTime).getSatelliteTime:110\n\tstorj.io/storj/storagenode/preflight.(*LocalTime).Check.func1:67\n\tgolang.org/x/sync/errgroup.(*Group).Go.func1:57”}
2020-04-15T22:07:12.317Z FATAL failed preflight check {“error”: “system clock is out of sync: system clock is out of sync with all trusted satellites”, “errorVerbose”: “system clock is out of sync: system clock is out of sync with all trusted satellites\n\tstorj.io/storj/storagenode/preflight.(*LocalTime).Check:96\n\tstorj.io/storj/storagenode.(*Peer).Run:656\n\tmain.cmdRun:209\n\tstorj.io/private/process.cleanup.func1.2:312\n\tstorj.io/private/process.cleanup.func1:330\n\tgithub.com/spf13/cobra.(*Command).execute:840\n\tgithub.com/spf13/cobra.(*Command).ExecuteC:945\n\tgithub.com/spf13/cobra.(*Command).Execute:885\n\tstorj.io/private/process.ExecWithCustomConfig:84\n\tstorj.io/private/process.ExecCustomDebug:66\n\tmain.main:329\n\truntime.main:203”}
[root@storj2 ~]#

The error is there you need to sync your systems clock.

If you use the Hyper-V, try to disable and enable back time synchronization in the Integration Services of VM.

Then check your network settings for this VM, if the problem is still persist

Thanks, I am indeed using hyper-v, I have done what you indicate, deactivate the time synchronization option, restart the virtual server with the same error, then activate time synchronization and the error continues the same.
The network configuration is the same as the node that is working

But this

exactly indication of the problem with the network.
Your DNS server 200.83.1.5 seems doesn’t work. Try to use 8.8.8.8 or 1.1.1.1 instead

same error, i can read the web site https://tardigrade.io/trusted-satellites from my node

2020-04-15T23:13:16.936Z WARN trust Failed to fetch URLs from source; used cache {“source”: “https://tardigrade.io/trusted-satellites”, “error”: “HTTP source: Get https://tardigrade.io/trusted-satellites: dial tcp: lookup tardigrade.io on 8.8.8.8:53: read udp 172.17.0.3:44913->8.8.8.8:53: read: no route to host”, “errorVerbose”: “HTTP source: Get https://tardigrade.io/trusted-satellites: dial tcp: lookup tardigrade.io on 8.8.8.8:53: read udp 172.17.0.3:44913->8.8.8.8:53: read: no route to host\n\tstorj.io/storj/storagenode/trust.(*HTTPSource).FetchEntries:63\n\tstorj.io/storj/storagenode/trust.(*List).fetchEntries:90\n\tstorj.io/storj/storagenode/trust.(*List).FetchURLs:49\n\tstorj.io/storj/storagenode/trust.(*Pool).fetchURLs:240\n\tstorj.io/storj/storagenode/trust.(*Pool).Refresh:177\n\tstorj.io/storj/storagenode.(*Peer).Run:652\n\tmain.cmdRun:209\n\tstorj.io/private/process.cleanup.func1.2:312\n\tstorj.io/private/process.cleanup.func1:330\n\tgithub.com/spf13/cobra.(*Command).execute:840\n\tgithub.com/spf13/cobra.(*Command).ExecuteC:945\n\tgithub.com/spf13/cobra.(*Command).Execute:885\n\tstorj.io/private/process.ExecWithCustomConfig:84\n\tstorj.io/private/process.ExecCustomDebug:66\n\tmain.main:329\n\truntime.main:203”}
2020-04-15T23:13:16.941Z INFO preflight:localtime start checking local system clock with trusted satellites’ system clock.

Perhaps related to this issue:

The probema is the firewall of my centos, I have deactivated it and everything works ok, I will check what difference it has with my other server.

Thank you very much for the help! :grinning: :grinning: :grinning: :grinning:

1 Like

This is the original configuration of my firewall, I have never touched anything there, I do not know why it stopped working

Node running Centos 8.1

[root@storj2 ~]# firewall-cmd --list-all
public (active)
target: default
icmp-block-inversion: no
interfaces: eth0
sources:
services: cockpit dhcpv6-client ssh
ports:
protocols:
masquerade: no
forward-ports:
source-ports:
icmp-blocks:
rich rules:
rule family=“ipv4” source address=“172.17.0.0/16” accept
[root@storj2 ~]#

run this command

firewall-cmd --zone = public --permanent --add-port = 28967 / tcp
firewall-cmd --zone = public --permanent --add-port = 14001 / tcp
service firewalld restart

and now everything works ok

[root@storj2 ~]# firewall-cmd --list-all
public (active)
target: default
icmp-block-inversion: no
interfaces: eth0
sources:
services: cockpit dhcpv6-client ssh
ports: 28967/tcp 14002/tcp
protocols:
masquerade: no
forward-ports:
source-ports:
icmp-blocks:
rich rules:
rule family=“ipv4” source address=“172.17.0.0/16” accept
[root@storj2 ~]#

I have restarted the server and I have had the same problem that I had in [this post](https://forum.storj.io/t/http-source-get-https-tardigrade-io-trusted-satellites-dial-tcp-lookup -tardigrade-io/5921/8) it seems that the solution did not work = (

Please, try one of the method from the