I cannot run the Qnap app with the Storj node. They can help?

Welcome to the forum @Pauantich!

What error message do you get ?

Thanks a lot!

CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES cfa9430838ba storjlabs/storagenode:beta "/entrypoint" 1 second ago Up Less than a second>14002/tcp,>28967/tcp storjlabsSnContainer 53d45171c739 storjlabs/storagenode:latest "/entrypoint" 24 hours ago Exited (1) 21 hours ago storagenode-1

It seems you haven’t entered DDNS. Try to show the config settings and blur out any personal info.

I have registered, I still cannot start the app node


I have already successfully configured no-ip. The address opens and takes me to the nas desk.

docker still does not run Storagenode.

Can you show content of the identity folder ? Does it have 6 files in it ?

I have created a path in File Station and there is no content

It needs to have the identity files in it. Did you follow the documentation ?

I have read the documentation for windows and linux, I have not found the documentation for a Qnap NAS.

this is the tutorial i followed:
Storj Qnap APP

about identity only describes in Linux, Mac and Win:

Also, I can’t get the Storj iso image from Docker to work, it doesn’t start

You can generate an identity on Linux, Windows or MacOS and transfer it to the NAS.
Also, if you have an ssh access to the QNAP, you can generate it there using binary for Linux, but it can be much longer, so use the screen command before the run.
You can run a docker version of the storagenode from the ssh terminal as well: https://documentation.storj.io/setup/cli

I have generated Identity on my PC and I have copied it to the container root. still not working. the log says:
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES 2289c47060be storjlabs/storagenode:beta "/entrypoint" 1 second ago Up Less than a second>14002/tcp,>28967/tcp storjlabsSnContainer a423a4622bea storjlabs/storagenode:beta "/entrypoint" 39 minutes ago Exited (1) 16 minutes ago storagenode-1

Container Station:
2020-06-03T21:06:48.523Z INFO Configuration loaded {“Location”: “/app/config/config.yaml”}

2020-06-03T21:06:48.523Z FATAL Failed to load identity. {“error”: “file or directory not found error: open identity/identity.cert: no such file or directory”, “errorVerbose”: "file or directory not found error: open identity/identity.ce

rt: no such file or directory\n\tstorj.io/common/identity.Config.Load:329\n\tmain.cmdRun:137\n\tstorj.io/private/process.cleanup.func1.4:359\n\tstorj.io/private/process.cleanup.func1:377\n\tgithub.com/spf13/cobra.(*Command).execute:840\n\tgithub.com/sp


it cannot find the specified path for identity.
Please, check the path

Hi @Pauantich - can you please make sure you have the latest version of the app? The earlier versions had RClone integrated(I see from your screenshot - thanks!).

1 Like

V1.0.0 I can’t start the wizard, it stays in the wallet from step 2 and doesn’t let continue.

I see that it can generate Identity, it is a great advance

@Pauantich - are you able to use the main config screen? Can you share a screenshot of step 2 with your wallet information hidden/obscured?

I click continue and it will not go to step 3

Looks like you copied your activation token instead of your wallet. You need to create an ethereum wallet and enter your wallet address there.

Use https://www.myetherwallet.com/ to create a wallet and use the ETH address shown to you in your wallet.

I, the logged in Mew Wallet, have been able to pass step 2 with the APP 1.0.0. Still not working