Ingress of 0 bytes

I haven’t been keeping track of my node in the last few weeks. When I checked just now I noticed that since the beginning of the month there has been 0 bytes of Ingres.

Storage Node Dashboard ( Node Version: v0.31.12 )

======================

ID 12mYxtBsxSKpbZrh1bwZ9kMrrPx2W9SxDu62qrJWaFHcsCb4xkV
Last Contact ONLINE
Uptime 312h8m29s

               Available         Used      Egress     Ingress
 Bandwidth        2.0 TB      12.1 GB     12.1 GB         0 B (since Mar 1)
      Disk        3.3 TB     331.1 GB

Is this expected? If not, how do I diagnose the cause of the problem and fix it?

Check if you node is disqualified in the web dashboard.

@kevink how do i do that? sorry for my ignorance but I’ve never used the web dashboard.

looks all i need to do was a remove/pull to get to the latest level and my Ingress started. Sorry for the false alarm.

I highly recommend using watchtower if you plan on not keeping an eye on your node for weeks at a time. It’ll take care of updates automatically.
https://documentation.storj.io/setup/cli/software-updates

Thx for the suggestion @BrightSilence, however, watchtower does not seem to work for the ARM distribution. I have had discussions in the following 2 threads for months now but as far as I am aware it has never been fixed:


Anyway, just in case you are asking. I do have watchtower running but based on the discussions in the 2 above threads was not expecting it to work and it hasn’t worked.

BTW, the simple resolution is to add the –platform aarch64 to the pull request of watchtower for ARM distributions but it doesn’t seem to have been done. At least this is what I do when I pull manually. It is not clear to me why the owner of the watchtower code is not doing this. I would think this would be just a simple if statement to check the current architecture it is running on. But not having access to that code I cannot assert that this is the case.

That was most likely the reason - you are only allowed to be 1 version behind the current one.

1 Like

I have been using watchtower on my rock64 since watchtower became available for Storj, and it has never failed to update my node.

@baker It initially worked for me as well but then stopped and as you can see in the threads I attached above it has not worked for a while. The only way for me to update since it stopped is to do it manually myself.