IPv6 does not work?

The 28967 port is closed on that address. Make sure that you have specified the address with a port.
In the docker version in the ADDRESS variable: -e ADDRESS="[2a03:10c3:259a:0:c09b:34e4:ae9c:24b9]:28967", in case of DDNS, it should be with port too.
To make it working, stop and remove the container:

docker stop -t 300 storagenode
docker rm storagenode

Then run the container back with all your parameters, include changed one.

For the Windows version you should check your kademlia.external-address: or contact.external-address: in the configuration file "%ProgramFiles%\Storj\Storage Node\config.yaml", it should be with port too.
If you would change this configuration file, don’t forget to save it and restart the storagenode service either from the Services applet or from the elevated Powershell:

Restart-Service storagenode

For all OSes make sure that your firewall has an inbound rule to allow requests from the any source and any port to the TCP 28967 port and your PC as a destination.
If your firewall has any outbound rules, then add an outbound rule to allow the access from the any port of your PC to the any host with any port as a destination. Usually the firewall doesn’t have an outbound rules.

The firewall could be on your router or other hardware, or integrated to your OS

when i check on the website that you send it is telling me it is open

the ddns name is ipv6001.dynv6.net

Some firewall is blocking traffic to your node

i have reconfigured the firewall now it is standing always open before sometimes on filtered
but still it is showing offline

For me it’s still closed even by IPv6.
It can’t be online, if your node is not reachable

is it necessary to add ipv6 to the docker run cmd for ipv6 to work along side ipv4 or amend the config.yaml

To use a dual stack, your external address should be resolved to the both stacks. It’s nothing to do with config.yaml, except update the external address, if you don’t have a DDNS domain yet before.
You can use this article for noip: https://www.noip.com/support/knowledgebase/create-hostname-ipv6-address-aaaa-record-support-question-day/
To enable IPv6 on docker you can use this article: https://docs.docker.com/config/daemon/ipv6/
But I don’t think it’s needed. I don’t have a IPv6 to check

i have now installed the version for windows on an windows node, the port is now always open when i check
but still the node is offline

(the new docker version blocks standart ipv6 )

i have now also added a ipv4 address voor updates from storj , now the node is online,
in ddns i have only used the ipv6 adress to contact to the node , how do i kwow that only ipv6 is used for data and not the ipv4

and will the ipv6 address be used for the gegraphic location and not the ipv4 / if i understand it correct storj uses subnet to spread the data equal to the nodes is this by ipv6 subnet / 64 or

Hi Alexey, I know this is an old thread but are you aware if there’s more customers using IPv6? Currently have to pay monthly for a static IP myself, not at a loss but wondering if there’s an increase at all if it’s available? I’ve been checking here https://www.google.com/intl/en/ipv6/statistics.html

I run dual stack servers for several different services.

Current number of Storj IPv6 clients:

lsof -nu storj |grep -i ipv6.*established |wc -l
2

Current number of IPFS public gateway IPv6 clients:

lsof -nu ipfs |grep -i ipv6.*established |wc -l
398

We doesn’t have any customer facing satellite with IPv6 yet. Satellites are hosted in the Google Cloud and they do not support the IPv6, even if our satellites are able to work with IPv6.
We have only one satellite with IPv6 support - Stefan

Thank you for that information.

Ok, I will keep to my £5 per month static IP. Still at a profit after that. :slight_smile:

Hello,

Did you find a solution to the problem?

I just posted an idea in the forum, now I have the same problem and it is happening to more and more people.

I would appreciate if you could comment on the thread.

Thanks

Hi guys.

Is there any update? Can we operate via IPv6? Or still must be on IPv4?

I found some interesting information:
This is old google cloud platform - Does gcp allow vm to have internal or external IPv6 address to vm instances - Stack Overflow , but point to the GoogleCloud VPC network overview  |  Google Cloud and it seems, that there isnt problem.

Can anybody from Storj give us update, please?

Actually I using IPv4 only for Storj …

Thank you!

Hello Adavan,

IPv6 is still not supported by the satellites due to more than just google/GCE not supporting it. We are having it on our radar. I am myself testing it already on the QA network with my testnet satellite:

For now, nodes are only working with IPv4 public address attached to it on the public, production network.

4 Likes

Hi @stefanbenten .
Thank you for information, we will waiting, but please, keep on mind, that requiring IPv4 will be more difficult over time :frowning: .

We do know that! And hence the work mentioned above! We are missing out on lots of nodes, bandwidth and opportunites, but it is a matter of balancing asks :slight_smile:

1 Like