My node is offline when i messed with my router settings

Dear Storj,
It’s been 1 and a half days since my node had been offline. I know that Storj recommends setting up a static router, but I’m new in setting up a static IP on the router. I watched a few tutorials on youtube about how to set up a static router but couldn’t understand a bit.
I have two routers set up. The secondary router connects to my computer.
At first, I tried to set it up using DHCP and dynamic IP which was previously correct.
I even connected using WIFI, when my ethernet cable broke. But there seemed to be no problem. But now, still, don’t get it why nodes are showing offline status.
Thank You
Dhiwahang Rai

First thing you should do is make sure the IP for the node hasnt changed if it has you will need to change the ip address that you set the port forwarding too.

I there any records or history showing what local IP i was using previously.
Because I had to factory reset to make the secondary router to recognize the internet access for that router?

No Theres no history if you reset and it pulled a new IP its easier to just start over and re open the IP that its being used right now.

I can see the IP address that is being used by my PC but want to know how do i restart and re open the IP that is being use now?

Which OS are you running your node on?

Windows 10 pro is the OS i’m running my node on, now!

Are you using The GUI or docker?

I am using the Windows GUI

Ok so its very simple just goto the config where you installed it. You will just edit it and change the IP you first set there. Edit the config.yaml file once you edit it goto powershell in admin and Stop-Service storagenode then after Start-Service storagenode

I originally signed the auth. token on windows but couldn’t run the docker because it needed virtualization technology to run the Linux container on docker. So I ran it on Ubuntu Server LTS. And when later, the GUI for Windows 10 Home came I migrated my node and the data to the Wind 10. I want to know which config.yaml file you are talking about? Is it the config file on the data or the Program Files/ Storj/…?

So where ever you installed the Windows GUI to

I searched for the word “IP” on the config file but couldn’t find any.

The only IP you will need to change is the IP you set your public ip too. You can get the IP for the node right in windows. Then you will just open the port like normal in your router. # the public address of the node, useful for nodes behind NAT

You said I should edit the IP on my config file so just wanna know what key words should i use to search it?

sorry, just missed the last part

i would setup ddns so you wont need to edit it again.

yeah, i had already set it up, but still “node status is offline”

Previously, i setted up virtual server in the forwarding option, IP and MAC binding, Address Reservation on the DHCP option, and the Dynamic DDNS. But the dashboard still says that my node is offline. Please tell me what I should do!

Did you update the ip though, your public ip