My Storagenode service wont start on Windows 10

I installed the windows program and restarted my computer but I cant get my storagenode service to start.
Im just getting “Service Storj V3 Storage Node ended unexpectedly” in Windows System log.

Go into windows services find the storage-node V3 service and click start.

I have tried that. Same thing. Nothing happens.

Can you check to see if your port is actually open? Also are you you on a CLI or GUI install?

Has your node ever been online or are you just starting?

How can i check that?

if you have a CLI install you use docker. GUI is better for windows.

I have installt the GUI for Windows.
I have done everything in the tutorial.

Do you have a static local ip? Also issue like this happen when people mess around in the config.yaml file… Did you try to change any settings? I had an issue like this when I messed up the config file when trying to set up a wan dashboard…

Yes and I have portforward 28967 to my PC.
Have done nothing in that file.

In the storagenode.log file
2019-11-22T19:54:20.011+0100 FATAL Unrecoverable error {“error”: "Error starting master database on storagenode: group:\n— mkdir Z:: Can not find the path.

My storage is on another computer. And I have maped a drive called Z:

path to store data in

storage.path: Z:\STORJ\

@blueon storage.path: Z:\STORJ\ make the disk lokal and not over smb

So I must have my harddrivers in the same computer as the Storj is running on?

Hi @blueon.
@Alexey has stated that Keep away from Network connected drives as they can get corrupted databases.
I think that Isci is the only thing he Said would work.
But do a forum search first so I dont give u the wrong answer.

But yes you should have the hdds in the same computer running your node for best performance

What is Isci ?
Okej. So now I have a linux computer that has the drivers but cant run docker.
And I cant run Windows and use the driver over the network.
What to do :frowning:

My node runs under 0.26.2 same problems. node offline since 13h
on version 0.26.1 all was ok
only this 2 Errors

2019-11-23T04:37:27.964+0100 INFO version running on version v0.26.2
2019-11-23T04:43:05.117+0100 ERROR telemetry failed sending report: lookup no such host
2019-11-23T04:44:05.605+0100 ERROR telemetry failed sending report: lookup no such host
2019-11-23T04:52:27.961+0100 INFO version running on version v0.26.2
2019-11-23T05:07:27.997+0100 INFO version running on version v0.26.2
2019-11-23T05:22:28.020+0100 INFO version running on version v0.26.2

Linux can run docker. Just put all storj files on the Linux computer. Just write the right Path to config files and storage files in the docker run command

Yes I know but Im getting errors.
So im gonna do the quick fix and install windows on the computer with all the drivers.
I have 3*5TB disk. what do you rekommend, 3 seperat disk or one big raid 5 disk?

The recomandation is one node per hdd.
If you start with one node per hdd fill up the first to 75% untill you start the second node.

Me i run 4hdd in RAID 5.
Small disks from start thats why Raid 5,

Okej, thanks for the advice.