Need Help: QNAP Storj App V. 1.1.3 Not Working - Service Unavailable

Hello Everyone,

I have a QNAP with fimware version 4.5.4.1741 that I’ve been trying to setup the Storj QNAP app on.

I was able to install Container Station, and then installed the Storj Storage Note app v. 1.1.0. When I tried starting it up, I got an error message saying: “Service Unavailable: The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.”

I then tried uninstalling and installing version 1.1.3 instead. I got the same error. Please see the attached screenshot.

Can someone please help on how to resolve this issue?

Thanks!

Hello @polymath ,
Welcome to the forum!

Please, show 10 last lines of your logs from the container.

I would recommend to use the CLI setup instead, see

i have the same issue. would you able to provide a videos to show how to fix it?

Hello @billgezi ,
Welcome to the forum!

Please, use the CLI installation instead, as suggested above.

Dear Alexey,

i installed docker, but when i run hello-world, below lines show up, would you please help to check whats wrong?
sudo docker run hello-world
docker: Error response from daemon: OCI runtime create failed: container_linux.go:380: starting container process caused: process_linux.go:545: container init caused: process_linux.go:508: setting cgroup config for procHooks process caused: bpf_prog_query(BPF_CGROUP_DEVICE) failed: function not implemented: unknown.
ERRO[0003] error waiting for container: context canceled

Is your model capable to run docker containers?
This error is related to docker, not to storagenode.
Perhaps you need to ask help the QNAP support or QNAP Community.

Could you please show the output of the command:

sudo docker info

To run a docker in qnap you need to install Container Station and then use the cli command:

docker pull storjlabs/storagenode:latest

docker run --rm -e SETUP=“true”
–mount type=bind,source="",destination=/app/identity
–mount type=bind,source="",destination=/app/config
–name storagenode storjlabs/storagenode:latest

1
docker run -d --restart unless-stopped --stop-timeout 300
2
-p 28967:28967/tcp
3
-p 28967:28967/udp
4
-p 127.0.0.1:14002:14002
5
-e WALLET=“0xXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX”
6
-e EMAIL="user@example.com"
7
-e ADDRESS=“domain.ddns.net:28967
8
-e STORAGE=“2TB”
9
–mount type=bind,source="",destination=/app/identity
10
–mount type=bind,source="",destination=/app/config
11
–name storagenode storjlabs/storagenode:latest

Client:
Context: default
Debug Mode: false
Plugins:
app: Docker App (Docker Inc., v0.9.1-beta3)
buildx: Build with BuildKit (Docker Inc., v0.6.3-docker)
scan: Docker Scan (Docker Inc., v0.9.0)

Server:
Containers: 6
Running: 0
Paused: 0
Stopped: 6
Images: 2
Server Version: 20.10.11
Storage Driver: overlay2
Backing Filesystem: extfs
Supports d_type: true
Native Overlay Diff: false
userxattr: false
Logging Driver: json-file
Cgroup Driver: systemd
Cgroup Version: 2
Plugins:
Volume: local
Network: bridge host ipvlan macvlan null overlay
Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog
Swarm: inactive
Runtimes: io.containerd.runc.v2 io.containerd.runtime.v1.linux runc
Default Runtime: runc
Init Binary: docker-init
containerd version: 7b11cfaabd73bb80907dd23182b9347b4245eb5d
runc version: v1.0.2-0-g52b36a2
init version: de40ad0
Security Options:
seccomp
Profile: default
cgroupns
Kernel Version: 5.10.60-qnap
Operating System: Ubuntu 20.04 LTS
OSType: linux
Architecture: x86_64
CPUs: 4
Total Memory: 3.678GiB
Name: ubuntu2004
ID: BDYL:2IIG:F3TA:QJCN:7ZJN:TUGW:ACF4:3VAA:OBIW:FNJW:3RIQ:QVOX
Docker Root Dir: /var/lib/docker
Debug Mode: false
Registry: https://index.docker.io/v1/
Labels:
Experimental: false
Insecure Registries:
127.0.0.0/8
Live Restore Enabled: false

WARNING: No memory limit support
WARNING: No swap limit support
WARNING: No cpu cfs quota support
WARNING: No cpu cfs period support
WARNING: No cpu shares support
WARNING: No cpuset support
WARNING: No io.weight support
WARNING: No io.weight (per device) support
WARNING: No io.max (rbps) support
WARNING: No io.max (wbps) support
WARNING: No io.max (riops) support
WARNING: No io.max (wiops) support

admin@ubuntu2004:~$ docker pull storjlabs/storagenode:latest
Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Post “http://%2Fvar%2Frun%2Fdocker.sock/v1.24/images/create?fromImage=storjlabs%2Fstoragenode&tag=latest”: dial unix /var/run/docker.sock: connect: permission denied
admin@ubuntu2004:~$ sudo docker pull storjlabs/storagenode:latest
latest: Pulling from storjlabs/storagenode
Digest: sha256:00b719a31761c28a25ad0d12fd9305080d835ba5a82eb38c16a84716d3d41939
Status: Image is up to date for storjlabs/storagenode:latest
docker.io/storjlabs/storagenode:latest

But are you trying to run the Ubuntu node in Container Station? I run it directly in Container Station without the need for Ubuntu

1 Like

You do not need to run a VM!
Just enable SSH, login to your QNAP and proceed. The Docker will be installed when you enable a Container Station in your QNAP.

i dont know how to run directly in the container station. would you please guide me? i am very new to using QNAP.
where to input - docker pull storjlabs/storagenode:latest in the container station?

i have container station. i dont konw how to input - docker pull storjlabs/storagenode:latest , would you please guide me?

I am also inexperienced but getting a docker to work is not difficult, I have qnap ts230.
First of all, do not open Container Station, the installation of the node must be done from a PC connected to the nas through a program that manages ssh connections, such as Putty. You install Putty on the PC, open it and connect to the nas via port 22.
In Putty you have to write the ip address of the nas, in my case 192.168.1.2:22. A terminal type screen opens, where you must first enter the administrator user of the nas, send and enter the relative password. When you type the password the cursor does not move but the password is written anyway, do enter and you are inside the SSH interface. You have to type q first then y to exit the help and finally you can proceed to install the node with the CLI commands

1 Like

I created a new shared folder called storj01 with two folders inside, identity and storage


In identity you put your identity, storage you leave it empty

Then open Putty2
Insert username and password
3
Type q and y to exit help4
And finally you are in the Putty interface5

From here you have to enter the guide commands:

  • Download the latest version first

docker pull storjlabs/storagenode:latest

  • Then you tell him where the folders are

docker run --rm -e SETUP=“true”
–mount type=bind,source="/share/storj01/identity/storagenode",destination=/app/identity
–mount type=bind,source="/share/storj01/storage",destination=/app/config
–name storagenode storjlabs/storagenode:latest

  • Then you give it the command to start it with your data

docker run -d --restart unless-stopped --stop-timeout 300 \
-p 28967:28967/tcp \
-p 28967:28967/udp \
-p 14002:14002 \
-e WALLET="0xXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX" \
-e EMAIL="user@example.com" \
-e ADDRESS="yourdomain.ddns.net:28967" \
-e STORAGE="2TB" \
--mount type=bind,source="/share/storj01/identity/storagenode",destination=/app/identity \
--mount type=bind,source="/share/storj01/storage",destination=/app/config \
--name storagenode storjlabs/storagenode:latest

Also you must have a static ip to the outside and open the doors of the router. If you don’t have a static ip you can use noip.
The nas also has a fixed ip in the local network, it is not in dhcp, otherwise it changes 192.168.1.2

3 Likes

thank you very very very much, finally have the node set up .

but it showing offline. would you please help?

I believe you need to open the ports on the router

Hello @Roberto

Can you please make sure that your web server is running so it will help you to run the app

1 Like

Hi @paragpadsumbiya
I left the web server turned off because I don’t use it. I am not using the storj app, I manage everything via ssh, it is simpler. To you, by activating the Web Server, does the app work?