No Route to Host: http://: Invalid host name


My node is in TrueNAS Scale. Something went awry with its network setting, but I got everything figured out except my Storj node. When I start the node, I get this error:

2023-08-30 23:02:36.606256+00:00downloading storagenode-updater
2023-08-30 23:02:36.608093+00:00–2023-08-30 23:02:36--
2023-08-30 23:02:36.665341+00:00Resolving (…
2023-08-30 23:02:39.740148+00:00Connecting to (||:443… failed: No route to host.
2023-08-30 23:02:39.742354+00:00http://: Invalid host name.

It looks it can’t reach the host, because there is none specified (i.e., I would expect the host name immediately after “https://”).

I check my WAN IP (correct), and ports 20988 and 28967 are both forwarded.

Suggestions, please? I altered no node settings at any point, and I’ve gone through everything I can think of. Thank you.

Ideally you would want to reach out to the TrueNAS folks because they wrote this plugin and support it.
It would seem like the app is trying to update itself but typically this is done through the app interface in TrueNAS and not automatically like a standalone Storj Node. So, they may have removed the ability of the node to update itself and you are seeing an error related to that.

I haven’t met many people on the TrueNAS Discord that have any knowledge of Storj. I have tried posting there in the past, without response (except to say I should try here).

It’s fairly stressful trying to get the node back up with the impending doom of being removed if offline too long…

I understand. Have you looked at the app interface in TrueNAS to see if there is an update you can apply? Perhaps if there is, it will update it and remove this error?

Yea, it says it’s up to date.

Not sure if this is relevant, but if I try to access the shell, I get:

error: unable to upgrade connection: container not found (“storj”)

Is your node running? Are you able to access the web interface and see the dashboard?

No, it never gets past Deploying.

Is it possible/sensible to just delete the TrueNAS app and reinstall the TrueCharts one? It’s a much more up to date app.

I see, so you never got this working. Did you follow the setup guide? Curious if you might be missing a step. I’m not familiar with TrueCharts so can’t say if that is a superior option. I have installed TrueNAS and installed a node within the interface, so I know it works but the configuration has to be correct otherwise you may run into errors like this.

Have you considered just running a node outside of the TrueNAS application?

Yes, I’ve had it working all month without issue. The issue just arose today after some other networking issue: I was attempting to install Pihole, but it caused problems with an interface and I abandoned it.

I literally yesterday bought an additional three 20 Tb drives for this NAS; I got all my eggs in that basket, for better or worse.

In the command line, can you do a “docker ps” and see if it lists the existing containers? It sounds like the container is not there for some reason. Did you move your drive configuration around or do anything that might have moved the container?

Only the deployed apps show up with that command.

No, I made no changes to Storj configs or its associated datasets in any way before this happened.

Time to get some sleep. Since I already had a few nodes in the 95% range, it seems likely this will lead to my expulsion. There are no exceptions for the first month or so, when one is still learning, I don’t think, lol

You have time. It sounds like the image hasn’t been added to docker. I would check the config in the app to see if anything has changed. Most likely it is still there but it needs to be added to docker with the same configuration flags that are in your config. For whatever reason it is failing to add it because it can’t find it.

Your NAS have a network issues, the deployed container is unable to contact some sites, include, this could be because the DNS from your ISP is not working.
You may try to configure as your DNS server on the router in the DHCP section to get it working.
It’s also possible that reboot of the NAS could solve a network issue.

Not sure it is DNS because it does resolve it just can’t contact it. Perhaps you have outbound connections blocked in your firewall? Or port 443 outbound is blocked.

Yea, this is what I thought (some DNS issue). However, everything else on the LAN is working.

I’ve checked the router, changed it from the ISP’s DNS to Quad Nine, rebooted it, and also changed the Global DNS settings in TrueNAS itself to Quad Nine (this is generally recommend best practice for TrueNAS).

And lastly, I have rebooted TrueNAS numerous times now.

Any Storj logs to check that might provide more details? Other suggestions?

TrueNAS has no firewall, and I’m still working towards (i.e., learning about) moving to pfSense as a LAN-wide alternative to my router/individual firewalls.

What could suddenly block port 443 outbound just for Storj? (no other LAN internet connectivity issues).

I’m only about a year into computers, so I appreciate your patience, guys. Working hard to learn, but oh, so much to learn.

Does your DNS settings have a default gateway setting? Possibly this is incorrect, so when it tries to route through it, you get the error no route to host.

Both the router and TrueNAS have set as the default ipv4 gateway.

Plus, if this were the issue, wouldn’t every host on the LAN be down, not just one, Storj ?

OK, I made progress! I was able to find an additional setting within TrueNAS that sets DNS for apps (not Globally). The strange thing is how this changed, without me changing it (didn’t even know of the setting).

Now, I’m having permissions issues. This is definitely the result of me playing with permissions while trying to solve the first issue. I should be able to solve this, we’ll see… May have a further question as I proceed.

Thank you both.