Node has zero ingress traffic after first month

I setup my first node in January and I started it 25/01/2022
For a month I saw traffic and space usage grew up to about 35 Gbytes
From 26/02 the ingress traffic is zero and the space usage is going down.
I checked the wathctower is running.
Storj log show only get and delete.
Yhe ingress traffic is zero from 26/2.

How can I check what is going on?


Hi and welcome.

What do your logs say? Any errors?

Where’s your node situated? (Country)

My node is in Italy.
Today I had the first error.
“error”: “order: unable to connect to the satellite: rpc: dial tcp i/o timeout”

But I can ping that address and I don’t have any rule that limits port connection. I can reach every port on satellite.

My node is behind a firewall. In input only TCP/UDP port 28967 is allowed.

I also can connect to satellite as you can see below.

$ telnet 7777
Connected to
Escape character is ‘^]’.

You need to ping your local IP + port, not the public satellite.
It seems that your node is not publicly available currently.

I tried to telnet my node from outside and I can connect to port 28967.

The node dashboard shows that node space used in TB*H go up and down every day.

In my log I see only get and delete command

What is your node version?

This is standard. The reporting is slow to update and relies on the satellites running order rollup processes.

1 Like

Version 1.46.3 running on debian 10.

What I don’t understand is why the space used grow (for example from 515.26 GBh to 554.21 GBh) and the ingress traffic is still zero for that day.

You need to update the version to 1.49.5, as it was released around the date your ingress stopped.

Your node will continue to make egress (and deletions) when running old node software versions but won’t receive ingress.


$ docker pull storjlabs/storagenode:latest
latest: Pulling from storjlabs/storagenode
Digest: sha256:4453c04c31a4d1f9d2cde1def7c060167839e40ad47c3b85773cf0feea447d97
Status: Image is up to date for storjlabs/storagenode:latest

What i’m doing wrong?

I restart docker and now it is at 1.49.5 and infìgress is growing.

So my problem was watchtower that doesn’t work well, i suppose.

It does sound like a watchtower issue if the new image wasn’t pulled.

Or watchtower doesn’t restart docker correctly.

Anyway I solved.
ThankYou so much.


Same for my node - I’ve updated manually as watchtower does not work anymore. Great to hear that it is fixed. Debian & Docker.

I can confirm the same on ubuntu docker.At last update watchtower does not updated my nodes automatically

1 Like

Do we have any idea what makes watchtower fail?
I read people have issues time to time, but I’m not sure we’ve got any lead on why that happens?

I don’t use watchtower and just pull images manually using docker-compose but it also thinks that it is already on the latest image of storj (currently running 1.48.2). I will try restarting the docker service.

  • It didn’t make a difference but in my case the node is still working fine for ingress/egress. I guess it depends when docker hub is updated to have “latest” tag pointing to the correct version.

My monitoring script alerts me in case there is an update available (with a buffer of 10 days in order to wait for availability in docker). That’s why I’ve removed Watchtower and do not rely on it any more.

I also have the feeling it might be more secure to update manually in order to watch the logs after the nodes restart - there were a couple of surprises with the last releases.

1 Like