Node offline and QUIC misconfigured

I’m setting up for the first time today, and it doesn’t work properly.

I followed the most recent instructions, so I’m already using

    -p 28967:28967/tcp \
    -p 28967:28967/udp \

I have restarted docker multiple multiple multiple multiple times. It. does. not. help.

I have confirmed that port forwarding is enabled in my router for both tcp/udp.

Opening the dashboard in an incognito window, I have this:

What further troubleshooting is available? I’m seeing the same advice over and over, none of it has helped me.

I’ve run docker stop and docker rm on the container around 15 times today trying to get this set up.

Either your application is broken, or your instructions are incorrect.

I’m on Linux.

Is there any advice that you can provide that isn’t just a repeat of 100 other posts that all say the same thing, which I’ve already tried without any success?

Sorry, new users can only embed one image per post.

Sorry, new users can only embed one image per post.

 ╰─λ docker --version
Docker version 20.10.16, build aa7e414fdc


 ╰─λ docker ps -a
CONTAINER ID   IMAGE                          COMMAND         CREATED          STATUS          PORTS                                                                                                                                         NAMES
90a27996837c   storjlabs/storagenode:latest   "/entrypoint"   21 minutes ago   Up 21 minutes>14002/tcp, :::14002->14002/tcp,>28967/tcp, :::28967->28967/tcp,>28967/udp, :::28967->28967/udp   storagenode

I’m running

docker run -d --restart unless-stopped --stop-timeout 300 \
    -p 28967:28967/tcp \
    -p 28967:28967/udp \
    -p 14002:14002 \
    -e WALLET="0xXXXXXXXX" \
    -e EMAIL="" \
    -e ADDRESS="XXXXXX:28967" \
    -e STORAGE="2TB" \
    --user $(id -u):$(id -g) \
    --mount type=bind,source=/storjnode/storagenode,destination=/app/identity \
    --mount type=bind,source=/storjnode,destination=/app/config \
    --name storagenode storjlabs/storagenode:latest

For IP address, I’m providing my actual public IP address. Once I get that working, I’ll switch to a service like noip or duckdns. I just want to see this work once, with as simple a config as possible.

Hello @mattzab ,
Welcome to the forum!

Please check your identity: Identity | Storj Docs

 ╭─root@arch in / took 2s
 ╰─λ grep -c BEGIN /storjconfig/storagenode/ca.cert

 ╭─root@arch in / took 3ms
 ╰─λ grep -c BEGIN /storjconfig/storagenode/identity.cert

 ╭─root@arch in / took 27ms
 ╰─λ docker stop a61bcf54841d

 ╭─root@arch in / took 736ms
 ╰─λ docker rm a61bcf54841d

 ╭─root@arch in / took 6s
 ╰─λ docker run -d --restart unless-stopped --stop-timeout 300 \
             -p 28967:28967/tcp \
             -p 28967:28967/udp \
             -p 14002:14002 \
             -e WALLET=0xCxxxxxxxxxxxxxxxxxxxxxxxxx \
             -e \
             -e \
             -e STORAGE=2TB \
             --user $(id -u):$(id -g) \
             --mount type=bind,source=/storjconfig/storagenode,destination=/app/identity \
             --mount type=bind,source=/storjnode,destination=/app/config \
             --name storagenode storjlabs/storagenode:latest


What can I try next?

Now it says that my node is outdated, and I need to upgrade to v.

Ok, how do I do that? I’m pretty sure I’m running latest everything

Sorry, new users can only attach one media per post.

I will completely start over, from step 1.

If any step causes an error, I will post it.

This is not needed. Your node seems doesn’t work (perhaps restarting), thus your web-dashboard doesn’t show real values. It also possible that your browser blocking some content (rare case), js for example.
Please provide the last 20 lines from your logs: How do I check my logs? | Storj Docs

Please try also to use a local dashboard

docker exec -it storagenode ./
 ╭─root@arch in / took 767ms
 ╰─λ docker exec -it storagenode ./
2022-05-15T07:20:00.277Z	INFO	Configuration loaded	{"Process": "storagenode", "Location": "/app/config/config.yaml"}
2022-05-15T07:20:00.278Z	INFO	Identity loaded.	{"Process": "storagenode", "Node ID": "eilustfxhukljk;dK"}
Error: rpc: dial tcp connect: connection refused

goroutine 36 [chan receive]:
/go/pkg/mod/ +0x3a
created by
/go/pkg/mod/ +0x2de

goroutine 35 [syscall]:
/usr/local/go/src/runtime/sigqueue.go:169 +0x98
/usr/local/go/src/os/signal/signal_unix.go:24 +0x19
created by os/signal.Notify.func1.1
/usr/local/go/src/os/signal/signal.go:151 +0x2c

goroutine 37 [select]:
database/sql.(*DB).connectionOpener(0xc000428680, {0x137f1f8, 0xc00012a9c0})
/usr/local/go/src/database/sql/sql.go:1196 +0x93
created by database/sql.OpenDB
/usr/local/go/src/database/sql/sql.go:794 +0x188
2022-05-15 07:44:19,472 INFO exited: storagenode (exit status 2; not expected)
2022-05-15 07:44:20,472 INFO gave up: storagenode entered FATAL state, too many start retries too quickly

storagenode does not work and throws exceptions. In this case 20 lines is not enough to show a full stack-trace.
Please try to provide an excerpt from logs since node start. You can use this service to upload archive with log file:, you can replace a private information with placeholders.

Pointing me at logs was a huge help, thank you!
I’ve solved the problem- it was a small myriad of things due to restarting the process and having leftover config.yaml files with conflicting information, then also not enough space (I had unmounted my external storage while troubleshooting), etc.

If I had been reading those logs from the start, I would have saved myself a decent amount of trouble. They made all the difference.

I think the panic it experienced at the end was simply an anomaly.

I’m up and running now, thank you for your troubleshooting advice! Whew!

1 Like