Node offline - Is it only 1 port i need to open 1.e 28967

HI, i am new here, buy really old member form first storj days.
i decided to give storj a go again about 3 months ago but failed. I am running 1 - 5Tb drive, I installed using the video tutorial, but get all the way to the end when i open http://localhost:14002/ I get node offline so checked port, it was offline came down to router issues, Now port is open, but i still get node offline and losing uptime check and still dropping because no band width is being utilised, I recently had a new router and ISP. Doubt this makes any difference, but i couldn’t open port 28967 originally, but now i have since i changed back to old router. I am also successfully running the no-ip app DUC v.4.1.1. which seems to be working ok(All green). Although i suspect this could have something to do with it, i am not sure yet. Do i have to add a port forward for the no ip app. And is there any other port i need to forward. I gave up a few months ago and then checked back last night and noticed some data however small has also downloaded, but still offline.

Can i add, i am on windows 10 in a virtual machine environment. Has anything else had the same issues when using VM

2020-02-23T11:15:04.166Z INFO preflight:localtime start checking local system clock with trusted satellites’ system clock.
2020-02-23T11:15:05.007Z INFO preflight:localtime local system clock is in sync with trusted satellites’ system clock.
2020-02-23T11:15:05.007Z INFO Public server started on [::]:28967
2020-02-23T11:15:05.007Z INFO Private server started on
2020-02-23T11:15:05.007Z INFO trust Scheduling next refresh {“after”: “4h53m35.808276865s”}
2020-02-23T11:15:05.008Z INFO bandwidth Performing bandwidth usage rollups
2020-02-23T11:15:05.072Z INFO piecestore:monitor Remaining Bandwidth {“bytes”: 2000000000000}
2020-02-23T11:15:05.121Z INFO version running on version v0.33.4

try to open in in Crome not IE

How many days/weeks/months your node was offline ?

Not sure, as i gave up but left vm running in background and pc is on pretty much 24/7

As suggested above open your dashboard ( http://localhost:14002/ ) in Chrome or Firefox or Edge NEVER in IE.

1 Like

I tried both. Still same. Just to add i reinstalled the node again. last night.

do you have port forwarding in your router? to your local IP?
Local pc use DHCP or you made static?
Firewall on VM?

I have used port forward in router, my router allows to open port using application as its a generic router form ISP. Rubbish, but i don;t want to start paying out stacks as it should be possible to still port forward. I had no issues with it on the old storj gui.

Local pc use DHCP or you made static? This is where my knowledge gets vague, how can i check. I do have a connection as i can access the internet from the vm, so assume the host is assigning ip address ok.

Firewall is open on vm, not sure if i opened on local would that make a difference do you think.


Its not static, should i be using the DUC software on host machine and not VM do you think.

whe you make port forward, it forward port to 1 IP addres, if it change, than forwarding not work any pore.
So you need to make pc IP static.

How can i do that? Do i need a static ip from ISP? Or do you mean static local ip? turning off DHCP

duc soft, only make static reference fot your external ip, but inside your local network you need to make static local pc by yourself. Some routers can make leeses, it will give you same ip to this pc all the time.

1 Like

you dont need to turn off dhcp, just can setup it on you local pc, jus google, and you find how to do it, set the ip that DHCP give it to you, and add DNS
gateway is your router ip

1 Like

Try static your local ip, you can do it from your machine or from your router too.
And make sure that your selected ip isn’t use by another device.

Example: from router side, Setting through DHCP server to reserved an IP for matched MAC address. Such as for AA:BB:CC:DD then do port forwarding which storj’s prefered port with ip

1 Like

No joy, i have lost connection to the vm. Got to goto work, will try later. Would it be easier to setup on host instead of vm

i run my nodes on windows 10, 5pcs

When you said change the DNS, Was you referring to the host connection or the vm connection? I found another post about this which is another one i get maybe because of DNS settings. ERROR telemetry failed sending report: lookup no such host
Here: Telemetry faild sending report: lookup no such host(solved)
But they also couldn’t ping, but i can from the vm. So why should it not be able to find the host?

try to flush dns on search in google how to do it write way.

Not sure if its the right way but i opened up CMD
Typed: ipconfig/flushdns

I have tried everything, when i setup a static, i lose connectivity to the internet. Nothing loads in browser not even the storj console http://localhost:14002/
I cant connect to satellites is my issue. Which is usually a port forward problem, but the port is open.

did you tried to restart your pc after you flushdns?
and if you make static ip, it shold be same network, you need also to gateway, and dns to be setuped.
can you post your config? no wallet, or email are needed.