Online starage yet offline nodes?

once i find out why. i will reboot it. i have fiber around 600down 300up 7ping. so i know it’s not the internet. it may be the config file. idk exactly how to configure it. if i can i don’t want to use docker although it’s running on my pc not begin used. i’ve been trying to figure this out for 2weeks. all i can say is help if possible. please and thank you in advanced.

@IncredibleGeek What do your logfiles say? They should be able to narrow the issue down.

the rest gets very redundant. with a message here and there. 2021-03-13T20:52:33.941-0500 INFO bandwidth Performing bandwidth usage rollups. and the redundant message is about failing to ping a satellite. the entire file is 18MB long. and i tried to post what i thought was important. idk how to link the whole thing as an attachment. unless i put it in a paste bin of some sorts.

Hello @IncredibleGeek ,
Welcome to the forum!

Seems you specified address of your node with http:// included, you should remove it and any remained slashes. It should contain only hostname and port via colon in your config.yaml file (see Where can I find the config.yaml? - Node Operator), i.e.

# the public address of the node, useful for nodes behind NAT
contact.external-address: "my.ddns.tld:28967"

Please, use a Notepad++ text editor to modify the config file. Explicitly save it (menu File - Save) and restart the storagenode service either from the Services applet or elevated PowerShell:

Restart-Service storagenode

I can see that audit scores for almost all satellites on your node are below the 60%, so your node is disqualified already. I can assume that you lost files.
If this node is new, maybe it’s better to start from scratch: delete the current identity and data, generate a new identity, sign it with a new authorization token and start with clean storage.

1 Like


i already had it like that. and i do use notepad++ . i use duckdns rather than no ip cause free instead of renew every 30 days. thank you tho. are there any other suggestions?

also what’s odd to me is 48.72% on 4 of them. 1 understandable. 2 coincidence. but 4. that’s a pattern. i was wondering if i could find out why that number and how to prevent it. also that online 0% was like that from the start. even when status was online. the bottom right one is how they all looked 24/7. idk if that’s normal.

i did create a new identity and will restart once i have some form of confidence that 48% won’t happen again. also want to know why 0% all the time. if possible. thank you.

wait after applying that you have to restart the node or does it apply automatically?

Did you check if your dyndns-service has the correct ip?
I had this once, because i swapped my router, dyndns was not updated, the nodes where online, but showed as offline, because they were not reached from outside.

If your hostname and port from the screenshot are the actual hostname and port:
i just tried to reach your storagenode via telnet, its not working.
While i can reach my own via telnet no problem.

i just shut it down and am now restarting it. just in case. impeccable timing tho. lol i just restarted it. oddly enough same nodes. i may have to delete the data on the drive. damn it.

problem. do i just delete blobs or do i remove all files and start all over?

Indeed. I can now reach it. :smiley:

nvm. i created a bk file moved all blobs into it. and everything back to normal… also they are 100% online now… ? i guess i just needed to restart my node after messing with yaml files. i thought they are just auto applied. i am was too used to linux. lol i couldn’t figure it out on linux so moved to window. if i can get it to work on linux i’d use ext4 it’s way more efficient than ntfs. until then o well. thanks for the help. i feel dumb.

is it possible to take existing files from first blob to 2nd one so i don’t lose 2gb transfered? cause who knows 2GB today. 2TB or more next time. so just a thought.

also thanks badfrog for testing it. :slight_smile: it gives me a bit of security knowing someone else can access it and not just on my end.

ok status is offline tho. so how are you able to connect? yet drives are online… i am soo confused.

ok in the yaml file. which comments to i remove the # cause they all reverted. afterwards i’ll restart the node… AGAIN. smh.

im just trying to connect to it directly though, maybe it cannot reach the network.
can you post your config.yml, maybe sth. is off there
(remove sensitive information though!)

only allowed 1 media per comment. so i sent the most important one. the rest are mostly # . hope you find something useful. if needed i guess i can find a paste bin of some sort and post it there and link it.

# how frequently bandwidth usage rollups are calculated# bandwidth.interval: 1 - i created a paste bin for this.

This Post contains 20 characters

After converting the listed domain to an IP (I get: and plugging the address into: Open Port Check Tool - Test Port Forwarding on Your Router
I get that the port is closed. If your system is still down, I’d try to bring it up and test with that site. If the issue persists, I’d verify the IP address that is matched to the domain and double check the port forward rules on your router.

i did and i’m still stuck. thanks tho. so now i know every edit you reset node. also my port on router is open and there was a site i used to check if opened. last time it was opened. this time it’s closed and same settings. so now idk.

Please, use this command to check what is actually saved on the disk:

sls "contact.external-address:" "C:\Program Files\Storj\Storage Node\config.yaml"

If it returns something different from what you typed - you likely did not save the config. Notepad++ can be closed with modified file, it will not ask you to save it. When you open editor again, it will open modified file (but not actually saved). Thus you need to click menu File - Save, confirm administrator’s rights and click on menu File - Save again. After that you need to restart your node.

Please also check your identity: Identity - Node Operator

Please, check your logs: How do I check my logs? - Node Operator maybe it’s stopped with some error.