max232
August 29, 2019, 3:59pm
1
This line is not marked as an error, but it is very different from the rest of the “INFO” lines.
Does anyone know what this is?
**2019-08-29T15:54:15.647Z INFO piecestore download failed {"Piece ID": "AXNYNZLQSU6FTH55AJPWK34BQCFDWG5EWFBPTNOVLOHA2KVXUT4Q", "SatelliteID": "118UWpMCHzs6CvSgWd9BfFVjw5K9pZbJjkfZJexMtSkmKxvvAW", "Action": "GET", "error": "piecestore: piecestore protocol: rpc error: code = Unavailable desc = transport is closing", "errorVerbose": "piecestore: piecestore protocol: rpc error: code = Unavailable desc = transport is closing\n\tstorj.io/storj/storagenode/piecestore.(*Endpoint).Download.func3:504\n\tgolang.org/x/sync/errgroup.(*Group).Go.func1:57"}**
Dylan
August 29, 2019, 4:04pm
2
This sounds like a port forwarding issue, are you on windows?
If so, try adding a new rule in your firewall:
Windows Defender Firewall->Advanced Setting->Inbound Rule->New Rule->Port
max232
August 30, 2019, 8:37am
3
Windows Defender Firewall - Disabled
There is a rule on the mikrotik router:
add action = accept chain = input dst-port = 28967 in-interface = ether24 \ protocol = tcp
ether24-wan
Odmin
August 30, 2019, 8:50am
4
Hi!
About Mikrotik router, you no need add input rule, just add a NAT rule:
/ip firewall nat
add action=dst-nat chain=dstnat comment="Storj v3" dst-port=28967 in-interface=ether24 protocol=tcp to-addresses=192.168.XX.XX to-ports=28967
Please replace 192.168.XX.XX to your node IP.
max232
August 30, 2019, 11:56am
5
All of this is indicated.
I have about 2 tb of data.
They could not boot if I had errors with ports and firewall
The Unavailable Transport is Closing message is basically the download equivalent of the RPC protocol Context Cancelled error for uploads. Either the uplink cancelled the download before it got 29 pieces, or it got all 29 pieces before yours completed and the result is that message. I will update the errors post.
1 Like
Note that I also occasionally get this error for uploads:
2019-08-31T23:35:53.956Z INFO piecestore upload started {"Piece ID": "TLIBI65CBLR55Z65W35XU7KXKYJJZ4UMNNWFC22TCIXPQ6L3B3FQ", "SatelliteID": "118UWpMCHzs6CvSgWd9BfFVjw5K9pZbJjkfZJexMtSkmKxvvAW", "Action": "PUT"}
2019-08-31T23:35:57.036Z INFO piecestore upload failed {"Piece ID": "TLIBI65CBLR55Z65W35XU7KXKYJJZ4UMNNWFC22TCIXPQ6L3B3FQ", "SatelliteID": "118UWpMCHzs6CvSgWd9BfFVjw5K9pZbJjkfZJexMtSkmKxvvAW", "Action": "PUT", "error": "piecestore protocol: rpc error: code = Internal desc = transport: transport: the stream is done or WriteHeader was already called", "errorVerbose": "piecestore protocol: rpc error: code = Internal desc = transport: transport: the stream is done or WriteHeader was already called\n\tstorj.io/storj/storagenode/piecestore.(*Endpoint).Upload:324\n\tstorj.io/storj/pkg/pb._Piecestore_Upload_Handler:851\n\tstorj.io/storj/pkg/server.(*Server).logOnErrorStreamInterceptor:23\n\tgoogle.golang.org/grpc.(*Server).processStreamingRPC:1127\n\tgoogle.golang.org/grpc.(*Server).handleStream:1178\n\tgoogle.golang.org/grpc.(*Server).serveStreams.func1.1:696"}
2019-08-31T23:35:57.036Z ERROR server piecestore protocol: rpc error: code = Internal desc = transport: transport: the stream is done or WriteHeader was already called
storj.io/storj/storagenode/piecestore.(*Endpoint).Upload:324
storj.io/storj/pkg/pb._Piecestore_Upload_Handler:851
storj.io/storj/pkg/server.(*Server).logOnErrorStreamInterceptor:23
google.golang.org/grpc.(*Server).processStreamingRPC:1127
google.golang.org/grpc.(*Server).handleStream:1178
google.golang.org/grpc.(*Server).serveStreams.func1.1:696
However, I also have plenty of successful uploads and downloads, so I don’t think it’s a port forwarding error.
Alexey
September 1, 2019, 1:07pm
8
This error is occur when the stream is closed too fast, so literally - the same, your node were late.
1 Like
Kar0le
October 8, 2019, 5:42pm
9
[admin@MikroTik]
/ip firewall nat add action=dst-nat chain=dstnat comment=“Storj v3” dst-port=28967 in-interface=ether24 protocol=tcp to-addresses=192.168.0.243 to-ports=28967
input does not match any value of interface
[admin@MikroTik]
Odmin
October 8, 2019, 5:53pm
10
Please change ether24 to your WAN interface
Kar0le
October 8, 2019, 5:59pm
11
the thing is that all was working some time ago with storjv2. Have no idea what changed since then.
“Please change ether24 to your WAN interface”
same sh…