Qnap Dashboard don't work

Hi, I have recently installed a storj node on my nas qnap TS230. The storj application is online, everything looks set up fine. When starting the node it automatically creates a storj docker but it does not start. in addition, the dashboard does not open. I have not made any settings via ssh because I am not able …
Thanks for your help

Did you run the setup?

Hello @Roberto ,
Welcome to the forum!

Please, enable ssh and perform the setup step (the QNAP app is outdated and doesn’t contain this step, and it’s required): Storage Node - Storj
Use correct paths to the identity and data. You can take them from the command via ssh:

docker inspect storjlabSnContainer -f "{{.Mounts}}"

Then you can start the QNAP-App and update the storagenode.

Hi Alexey,
thanks for the help. I deleted the Storj app I had installed via appcenter and deleted the containers
Now, I am not familiar with Putty, I am following the tutorial from your site. I copied command1:
docker pull storjlabs / storagenode: latest

Putty tells me
(processing)

I also ran the other 2 commands:
docker run --rm …
and
docler run -d …

but these also answer me (processing)

The dokcker ps -a command also sends me back (processing)

Are the commands instantaneous?
How do I know what’s going on?
If the command was successful?
Should I check on the Nas?
Should I reinstall the Storj app I previously downloaded from github?

I’m sorry but I’m a neophyte
Thanks for your patience

and wishes for Easter :slight_smile:

It could take a time to execute a command (I cannot say for sure, because I do not see, what are you doing), but not minutes.
You can check, if the container running by command

docker ps

If it’s running, then ok. For the setup step it should execute and exit. For the regular docker run it should be running after start.

You can install the QNAP app back, if you want. But it’s not needed, if you run it from the command line. Just check that it’s running.
If you not sure - you can post your docker run command (remove personal info) here between two new lines with three backticks ``` on each.

Hy,

docker run --rm -e SETUP=“true” --mount type=bind,source="/share/Public/xxx/xxx/xxx,destination=/app/identity --mount type=bind,source="/share/Public/Storage",destination=/app/config --name storagenode storjlabs/storagenode:latest

docker run -d --restart unless-stopped --stop-timeout 300 -p 28967:28967 -p 127.0.0.1:14002:14002 -e WALLET=“xxx” -e EMAIL="xxx@gmail.com" -e ADDRESS=“xxx.ddns.net:28967” -e STORAGE=“xTB” --mount type=bind,source="/share/Public/xxx/xxx/xxx",destination=/app/identity --mount type=bind,source="/share/Public/Storage",destination=/app/config --name storagenode storjlabs/storagenode:latest

Looks correct.
Is the node running?

docker ps

If it’s restarting - try to check logs:

docker logs --tail 20 storagenode

also for the command

docker ps

the answer is always (processing)

I repeat, I’m not an expert on ssh or qnap

at point 6 the container appears to be active

Cattura stor2j

You need to press „Q“ and then enter to quit that qnap-menu. After that you need to confirm with „y“ and enter and after that you will have access to the real cli. There you can execute „docker ps“ or any other command :slight_smile:

1 Like

Thanks for your help. striker43 realized that I lack the basics :slight_smile:
This is the result


the dashboard does not start, I think it is a port problem
the docker restarts

I had misspelled the amount of memory.

now it seems that something is working
Cattura6
now only the web dashboard is not working

Maybe I succeeded ???

Looks good :+1: :smiley:

:slight_smile: Yes, it seems to work. But is there any way to monitor the node outside the home?

There is some documentation for that - How to remote access the web dashboard - Storj

In my case, I have a qnap, I don’t have to install an ssh server, it already is.

I am trying with Terminus on ios, but I cannot log in

You need to forward some non-standart port to the 22 port of the QNAP and use that non-standart port to connect from outside (this is to make difficult to hack your QNAP, because 22 port is well known and you will see constantly attempts to brut-force your admin password).
Also, please, use only keys authentication and disable password authentication: SSH: How To Set Up Authorized Keys - QNAPedia and https://forum.qnap.com/viewtopic.php?t=47222
Unfortunately QNAP will reset it on every reboot and the password authentication will be enabled again.
It’s very unsecure or your password should be really strong (more than 20 chars).
Perhaps you can install something like a fail2ban for QNAP, I’m not familiar with their ecosystem.

ok guys, thanks for the help, but for now I only manage the node from home. When Storj makes a client application I will fix the problem :slight_smile:

1 Like