Reported trash size stuck at 7 TB alhough there is 0.8 TB trash occupied space on the disk

Setup: Windows10, bare metal, Node Age 57 Months, v1.104.5
Dashboard reports

Used: 6.71 TB
Free: 12.24 GB
Trash: 7.28 TB
Overused: 0 B

But, in fact, folder e:\storj\storage\trash\ size on disk is 0.8 TB. The disk is 14TB size, there is no other data on the disk, solely for that single storj node, and no other node on the PC. Suspension and Audit is all fine 100%.
I wouldn’t care, but the node is not taking any more incoming traffic since it thinks the disk is full, although there is 6.4 TB free space on the disk. I firstly noticed it some two weeks ago, it did not change since then. Before there was about 12TB used and less than 1 TB trash.
A month ago I manually deleted leftovers from the decommed satellites. Now content of e:\storj\storage\trash\ are following 4 folders only: pmw6tvzmf2jv6giyybmmvl4o2ahqlaldsaeha4yx74n5aaaaaaaa qstuylguhrn2ozjv4h2c6xpxykd622gtgurhql2k7k75wqaaaaaa ukfu6bhbboxilvt7jrwlqk7y2tapb5d2r2tsmj2sjxvw5qaaaaaa v4weeab67sbgvnbwd5z7tweqsqqun7qox2agpbxy44mqqaaaaaaa
and file .trash-uses-day-dirs-indicator
All these folders contain another folders that go by names 2024-05-27 and later, nothing else, nothing older.
Troubleshooting done: checked log, no errors except lost race up/downloads, lazy filewalker completed successfully. I tried to set storage.allocated-disk-space: 16 TB to force it use 2 more TB from the free space, but the node dashboard still shows Total Space 14 TB. It apparently checks the physical disk size and does not allow me to set more, whatever number higher than 14 it does not follow.
I have been having storage2.piece-scan-on-startup: false active for some time, but week ago I removed it and no change.
So, the question is, how can I reset the amount of reported trash back to reality to make the node use the free space again?


image

Hello @xsys,
Welcome back!

You need to allow to finish the used-space-filewalker to update state in the databases.
If you didn’t disable a startup scan (or if you do not know what’s am I talked about), it should update databases after a restart (it may take days, depending on your system).
If you disabled it - please, enable back or comment out, save the config and restart the node.

Oh that’s awesome fast reply, thanks alot :slight_smile:
Yes I removed the storage2.piece-scan-on-startup: false from my config almost week ago, is it possible it takes so long? Please what message I will see on the Log when it is completed?

depends, if you use a VM or a network remote storage - it’s quite possible to spent at least a week to just scan (and another one to delete…).

ok thanks I will give it more time

1 Like