Storagenode Docker container keeps restarting with exit code 1

My storagenode container won’t stay up for more than 30 seconds.

Output of logs indicate database is locked?


Error: Error starting master database on storagenode: database: info opening file “config/storage/info.db” failed: database is locked
storjio/storj/storagenode/storagenodedb.(*DB).openDatabase:331
storjio/storj/storagenode/storagenodedb.(*DB).openExistingDatabase:308
storjio/storj/storagenode/storagenodedb.(*DB).openDatabases:283
storjio/storj/storagenode/storagenodedb.OpenExisting:250
maincmdRun:193
storjio/private/process.cleanup.func1.4:377
storjio/private/process.cleanup.func1:395
githubcom/spf13/cobra.(*Command).execute:852
githubcom/spf13/cobra.(*Command).ExecuteC:960
githubcom/spf13/cobra.(*Command).Execute:897
storjio/private/process.ExecWithCustomConfigAndLogger:92
main.main:478
runtime.main:250
2023-02-12 22:14:35,465 INFO exited: storagenode (exit status 1; not expected)

Docker run command:

docker run -d --restart unless-stopped --stop-timeout 300
-p 28967:28967/tcp
-p 28967:28967/udp
-p 14002:14002
-e WALLET=“XXX”
-e EMAIL=“XXX”
-e ADDRESS=“XXX:28967”
-e STORAGE=“5TB”
–user $(id -u):$(id -g)
–mount type=bind,source=“/storj”,destination=/app/identity
–mount type=bind,source=“/storj”,destination=/app/config
–name storagenode storjlabs/storagenode:latest

Hello @kduensing,
Welcome to the forum!

Do you use a network filesystem like NFS, CIFS/SMB, etc.? The network filesystems doesn’t supported and not recommended.
Please show result of the command

df --si -T

Unavailable to run the command, but I can say that it is an NFS share.
That being said, any recommendations to make use of extra space on my Synology if I can’t use NFS or SMB? I was hoping to use a Zima board as the storage node.

Hi @kduensing
You can run the node directly on the Synology device.

If your Synology is unable to run either docker or storagenode binary, then you can use iSCSI.

iSCSI was the trick I was looking for. Everything is up! I greatly Appreciate it.