Storj V3 Node Raspberry Pi 3 got connection refused on port 22

Hi Storj forum operators! I got the node setup for about 20 days now. A little bit of backstory, about 3 days ago my ISP cut my wifi due to me forgetting to pay the monthly bill and plummeting the node into a 3 hours downtime. Today, I’m met with another problem. I cannot SSH into my Raspberry Pi anymore and the error it keeps returning is
ssh: connect to host port 22: Connection refused
However, the node seems to be running okay without any problem. The only thing that’s not working is SSH. I don’t know if its even safe to perform a fast reboot in fear of a reduction in my reputation points.
I hope you guys can help me out with this sticky situation and my node is still currently in the testing month by the way. Thank you! :slight_smile:
I’m running MacOS and the Pi is on Raspbian Buster.

Welcome to the forum @khvnhtung!

Since your internet was down and you got it up later, this address could be different now. Can you double check it ?

1 Like

I knew it would happen someday so I managed to set an internal static ip for the device. Thanks

1 Like

The IP is still but the problem still persists. Should I do a reboot?

Found a troubleshoot post

1 Like

The troubleshoot post is for problem when connecting from outside the network so I don’t think it applied to me (local network). I even tried rebooting the pi but the problem stays…

Isn’t the IP your router IP address? Your Pi should have a different local IP address.

1 Like

My router IP address is though.

The RPi is known to have issues with ssh access randomly malfunctioning.

I’ve run in to this problem myself and you can find plenty of examples on RPi StackExchange … I’ve even answered some of those questions myself once upon a time…

If you have a locally setup keyboard and monitor, I would suggest restarting the ssh server and see what happens.

1 Like

Ive never seen the next IP use though normally it starts with , Did you manually set it to use

1 Like

I have. Many routers start the dhcp pool at and those that don’t start higher so you can user the lower IP addresses for static IP’s. Not uncommon at all. is reserved for private LAN use. Such addresses are not Internet addresses

Yea some reason I thought this was one of the reserved IP addresses but your right if you use it as a static IP address your able to use the next IP. But first I thought it was the router IP cause its commonly known as the IP address for certain routers.

I didn’t manually set it, the first thing I done after resetting my wifi router (Once forgot admin password) was connecting my Pi to it and that’s where it got from lol

I don’t have a screen here so I’m thinking of shutting it down, pull out the sd card, create an ssh file to see if it can trigger the Pi to re-enable SSH and put all of them back.

That’s worth a try. Did you try that and did it solve the issue?

Hi, last might was too late so I haven’t had the chance to do it yet. I think I will make use
of the March servers maintenance in order to perform this fix.

It isn’t recommend to use this time for maintenance.

1 Like

Thanks for the heads up. A few minutes ago I turned the Pi off, create an ssh file and now it’s working again. The entire process took 1 minutes. I’ve also run an audit script to check how many tests I’ve to undergo until I can be verified and it shows that I’m currently having 44 successful audits so I will have to wait 56 more audits before my node can receive real data right?

Also, in order to run the file, it is recommended to copy data over to another folder to run to avoid corruption so all I need to do is copy the folder in /mnt/storagenode to a new folder and run it from there right? Can I copy the folder while docker is running?