Synology NAS Docker stopped Storj node. Char 409 error

I got the node stopped unexpectedly from yesterday. It was running 24/7 flawlessly from 1 year and now suddently stopped and cannot start.
I reinstalled the node setup but have the same issue.
Here is the log from NAS Container Manager looks like:

and here is the command used to setup node:

sudo docker run -d --restart unless-stopped --stop-timeout 300 \
    -p 28978:28967/tcp \
    -p 28978:28967/udp \
    -p 192.168.100.5:14002:14002 \
    -e WALLET="0x94b34aa53c3b57e4844e8fd896ad3c1d43c45209" \
    -e EMAIL="MY_EMAIL" \
    -e ADDRESS="MY_IP:28978" \
    -e STORAGE=“11TB" \
    --mount type=bind,source="/volume1/docker/storj/identity",destination=/app/identity \
    --mount type=bind,source="/volume1/docker/storj/data",destination=/app/config \
    --name storagenode storjlabs/storagenode:latest

I used different ports for TCP/UDP as I have another node in the same IP that runs for test purposes only.

What’s the last error?

Hello Alexey,

I checked out and I can only see this error in log:

The container stopped and keep sending this error when I try to start the node again.
Should I check somewhere else the error log?

Did you update DSM or some app or Container Manager/Docker?
The updates are put on manual or auto?

Please make sure that you used only straight quotes " and not a curly ones and , use double dashes -- and not hyphens .
Use a plain text editor to form the command, not word processors, because they could replace all these characters to a fancy ones but incompatible with the terminal.

1 Like

Does -e expression 1 means the wallet address? Maybe you got hacked and they changed the wallet?
I would stop and remove the container, change the SSH port to something else than 22, maybe investigate if something nefarious is running on the machine, and restart the container after copy-paste the wallet address from the wallet app into the run command.
They can change a few characters and you miss them on a quick look. I heard so many cases of changed addresses that looked so similar to the original one.
Of course, do what Alexey sugests, use Notepad++ to edit commands, use straight quotes, double dash --, etc, but I imagine these are not the problem if the node worked untill now and you didn’t input anything.
I would mask the wallet address also when post on forums. You can use the option “<> insert code”, to paste your command in the forum. It would format it better.

Inchecked and all updates are latest in all apps and DSM

Looks like the error is similar to

So, perhaps special characters have been passed, or used a variable in the value(s) of -e options.

I saved my last paraghraph used to work before, bout double checked what you suggested now. All seem to be ok as text punctuation.
I am thinking to migrate it to a windows pc, but I guess copying almost 10tb of data will take longer than the node will be disqualified from the network…
What do you recommend to do here?

If you want to migrate to Windows, you may use this guide:

But perhaps it’s not a good idea, because your Windows PC likely will use more power than a Synology NAS.

I formatted your command in your first post, and noticed, that you use a curly quote in the -e STORAGE option, but only the first one, see:

Nope. This one is wrong:

You are both right! Changed that comma and now the containter is starting, but in restarts every few seconds. Te log looks like this from DSM:

Should I get more lines from log file it its helpful?

Restarted the container: is trying to start couples of times then stopped.

Tried to start again the container today, and i got this log errors:

Just check ports and everything. Compare my comms with yours, maybe you missed something.
https://forum.storj.io/t/my-docker-run-commands-for-multinodes-on-synology-nas/22034

I believe you still has some fancy symbols in your docker run command, since the container is restarting with throwing out of help messages.

I think you are right, as long as nothing was changed in terms of ports settings etc. before container crush.
Below is the commands I did yesterday to remove and reinstall again the container. Perhaps something is not right here… but I cannot see it

sudo docker stop storagenode

sudo docker rm storagenode

sudo docker run -d --restart unless-stopped --stop-timeout 300 \
    -p 28978:28967/tcp \
    -p 28978:28967/udp \
    -p 192.168.100.5:14002:14002 \
    -e WALLET="0x94b34aa53c3b57e4844e8fd896ad3c1d43c45209" \
    -e EMAIL="xxxxxxxxxxxxxx" \
    -e ADDRESS="xxxxxxxxxxxx:28978" \
    -e STORAGE="11TB" \
    --mount type=bind,source="/volume1/docker/storj/identity",destination=/app/identity \
    --mount type=bind,source="/volume1/docker/storj/data",destination=/app/config \
    --name storagenode storjlabs/storagenode:latest

In noticed a strange notification in synology container manager, when i tried to remove the container from the app:

Maybe could ring a bell to someone about this one. Nas is working well. I did a speed test and there are the same results as before this unfortunate event.

What is the name of the other storagenode?
One has to be storagenode, the other storagenode2, with different identity and different paths for each, if both are on the same machine.
Check the run command for both at the paramether:
–name
And you need to use different ports for server address I believe. So you need to add one more paramether or edit the config.yaml.
Also, change the log level, because now, it uses the one set in config.yaml, and the default is info, which will fill up your drive quicker than the client’s data.

I am using another node but it is in different machine. Synology have just one container.

This is how the port fwd in my router looks like.