[Tech Preview] Multinode Dashboard Binaries

I believe so. You need to rollback it to 1.69.2

Yes, my multinode dashboard is also not working, for a couple of months now, even with 1.69.2. I think the downgrade doesn’t work since the problem on the graphs starts from single nodes on v1.70.2

The bug with storage usage graph is introduced in v1.70.2 of storagenode, so it will report it wrongly to the multinode dashboard as well independently of multinode dashboard version, checked with v1.68.2, v1.69.2 and v1.70.2

1 Like

20 posts were split to a new topic: Multinode dashboard for storj-sim test network

Hello Alexey, I gone through the topic, but I didn’t found some guide how to setup this dashboard.
Can you advise there to find the manual or maybe how to do this? At the moment my nodes running under Docker for Windows 10

Regards,
Alexander

1 Like

Hello @Aka985,
It’s in the top message of this topic.
There is no installer, only binary.
In this topic the Community made a docker image: Multinode Dashboard Docker image

There is also an official Docker image.

If you want to add a node, you need the node ID and the api key. You get both with the following: (replace storagenode1 with the name of one of your storagenodes)

docker exec -it storagenode1 /app/storagenode issue-apikey --config-dir config --identity-dir identity --log.output stdout
2 Likes

Hey, can some one explain me what i have did wrong?
everything was made by this instruction:

root@vmi1576767:/opt/multinode# docker run -d --restart unless-stopped \

--user $(id -u):$(id -g) \
-p 15002:15002/tcp \
--mount type=bind,source=/opt/multinode,destination=/app/config \
--name multinode storjlabs/multinode:latest

25056c5adc0e269636a3f30c7e6de77d805883e8a5a0fb2ca4efc0eed4476dbb

root@vmi1576767:/opt/multinode# docker logs multinode
2024-01-01T18:48:55Z DEBUG process/tracing.go:104 Could not read identity for tracing setup {“error”: “open ./identity.cert: no such file or directory”}
2024-01-01T18:48:55Z INFO process/tracing.go:73 Anonymized tracing enabled
2024-01-01T18:48:55Z DEBUG tracing collector monkit-jaeger@v0.0.0-20230707083646-f15e6e8b7e8c/thrift.go:149 started
2024-01-01T18:48:55Z DEBUG tracing collector monkit-jaeger@v0.0.0-20230707083646-f15e6e8b7e8c/thrift.go:206 stopped
2024-01-01T18:48:55Z INFO process/exec_conf.go:318 Configuration loaded {“Location”: “/app/config/config.yaml”}
2024-01-01T18:48:55Z DEBUG process/tracing.go:104 Could not read identity for tracing setup {“error”: “open ./identity.cert: no such file or directory”}
2024-01-01T18:48:55Z INFO process/tracing.go:73 Anonymized tracing enabled
2024-01-01T18:48:55Z DEBUG tracing collector monkit-jaeger@v0.0.0-20230707083646-f15e6e8b7e8c/thrift.go:149 started
2024-01-01T18:48:55Z DEBUG db multinodedb/database.go:72 Connected to: {“db source”: “file:config/master.db?_journal=WAL&_busy_timeout=10000”}
2024-01-01T18:48:55Z INFO db migrate/versions.go:216 Database Created {“version”: 0}
2024-01-01T18:48:55Z DEBUG servers lifecycle/group.go:100 started {“items”: [“console:endpoint”]}

Moreover, if i will try to resolve issue with certificates and give it to multinode container, it doesnt solve anything, error disappears, but dashboard is still not accessible…

You need to allow the multinode dashboard port TCP 15002 in your firewall.
I just checked and it works.

root@vmi1576767:~# ufw status
Status: inactive

Make sure that your user $(id -u):$(id -g) has an access to /opt/multinode, or make it the owner:

chown $(id -u):$(id -g) -R /opt/multinode

I read all the messages and I can’t find why the button to “add node” doesn’t do anything. I’m going to try the docker image to see if I have better luck.

Use the command on your node:

docker exec -it storagenode ./storagenode info --config-dir config

Then use the printed information to add a node to the multinode dashboard.
The external address you should add with a port (the docker node will not show it), it should be the same as the value of -e ADDRESS= option.

Try to use a different browser. I just checked - and it works.

the issue was that dashboard was accessible only from “localhost”, even if port was mentioned in this way: -p 15002:15002/tcp
resolved this by using nginx proxy manager

It’s also opening on the local IP. So likely the network configuration or firewall.
You may also specify the IP of your interface in the -p option: -p 192.168.1.11:15002:15002/tcp and it will listen only on that address and port.

Hi,

Not sure what I’m doing wrong here to generate the json:

I’m running node version 1.95.1

Can anyone help out?

You missed the command info

Thanks, that was me being dumb.

A few questions, I couldn’t set it up on the same device that holds my 3 nodes because the public IP wouldn’t route properly. However, I was able to set it up outside of my network no problem. Any reason for that?

Also, this seems add to me:


I have so much empty space but can’t see all of my wallets at once?

You should be running all your nodes on the same wallet address as per Node Operators ToS

2 Likes