Unknown flag: --mount

Hello , i have install storj on Linux untill last comment it was sucssefully installed when i hit this command on command port

docker run -d --restart unless-stopped --stop-timeout 300
-p 28967:28967
-p 127.0.0.1:14002:14002
-e WALLET=“0xXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX”
-e EMAIL="user@example.com"
-e ADDRESS=“domain.ddns.net:28967
-e STORAGE=“2TB”
–mount type=bind,source="",destination=/app/identity
–mount type=bind,source="",destination=/app/config
–name storagenode storjlabs/storagenode:beta

I getting
unknown flag: --mount
See ‘docker run --help’.

Any idea ?

my real mount path is
–mount type=bind,source="/root/.local/share/storj/identity/storagenode",destination=/app/identity
–mount type=bind,source="/storjfile",destination=/app/config \

Here is my RAID0 Patation look like

[root@53535 ~]# df
Filesystem 1K-blocks Used Available Use% Mounted on
devtmpfs 8114588 0 8114588 0% /dev
tmpfs 8126380 0 8126380 0% /dev/shm
tmpfs 8126380 9012 8117368 1% /run
tmpfs 8126380 0 8126380 0% /sys/fs/cgroup
/dev/sda3 3843262592 1670172 3646341784 1% /
/dev/sda2 194235 121295 58604 68% /boot
tmpfs 1625276 0 1625276 0% /run/user/0

docker run -d --restart unless-stopped --stop-timeout 300 \
    -p 28967:28967 \
    -p 127.0.0.1:14002:14002 \
    -e WALLET="0xXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX" \
    -e EMAIL="user@example.com" \
    -e ADDRESS="domain.ddns.net:28967" \
    -e STORAGE="2TB" \
    --mount type=bind,source="<identity-dir>",destination=/app/identity \
    --mount type=bind,source="<storage-dir>",destination=/app/config \
    --name storagenode storjlabs/storagenode:beta

Your docker run command line is missing backslashes at line endings

take look tutorial there no black slash at end of line

https://documentation.storj.io/setup/cli/storage-node

Please read documentation

1 Like

Yes i mean i copy from source page and past in to text editor so there is blackslash at the end

here is my orginal code look like

> docker run -d --restart unless-stopped --stop-timeout 300 \
>     -p 28967:28967 \
>     -p 127.0.0.1:14002:14002 \
>     -e WALLET="removed" \
>     -e EMAIL="removed" \
>     -e ADDRESS="removed:28967" \
>     -e STORAGE="3.6TB" \
>     --mount type=bind,source="/root/.local/share/storj/identity/storagenode",destination=/app/identity \
>     --mount type=bind,source="/mnt/storjfiles",destination=/app/config \
>     --name storagenode storjlabs/storagenode:beta

I fallow this static Mount too
https://documentation.storj.io/resources/faq/linux-static-mount

I tired to use -v instead of --mount here is output look like

/usr/bin/docker-current: Error response from daemon: invalid volume spec "type=b                                            ind,source=/mnt/storjfiles,destination=/app/config": invalid volume specificatio                                            n: 'type=bind,source=/mnt/storjfiles,destination=/app/config': invalid mount con                                            fig for type "volume": invalid mount path: 'type=bind,source=/mnt/storjfiles,des                                            tination=/app/config' mount path must be absolute.
See '/usr/bin/docker-current run --help'.

Here is my mount disk path

sda3 ext4         f77fd259-213d-40b3-b874-91b81cae0af7 /mnt/storjfiles


NAME   MAJ:MIN RM  SIZE RO TYPE MOUNTPOINT
sda      8:0    0  3.7T  0 disk
├─sda1   8:1    0    1M  0 part
├─sda2   8:2    0  200M  0 part /boot
├─sda3   8:3    0  3.7T  0 part /mnt/storjfiles
└─sda4   8:4    0    1G  0 part [SWAP]

DO NOT USE -v and follow the documentation.

I would recommend setting your storage to 3.5TB to be safe. You need to keep 10% as overhead to avoid your node getting in trouble of over-allocation.

Can you show the screen where you enter the command?

1 Like

i use putty … do you want screen shot ?

Here here output of docker ruining test

[root@PAR-193655 ~]# docker ps -a
CONTAINER ID        IMAGE               COMMAND             CREATED             STATUS                         PORTS               NAMES
fe89f964eead        hello-world         "/hello"            About an hour ago   Exited (0) About an hour ago                       sharp_agnesi
5bf42af4d59d        hello-world         "/hello"            4 hours ago         Exited (0) 4 hours ago                             festive_pasteur

Try entering the command in 1 single line without using the enter key. You can copy it from documentation and edit the fields with your info.

I didn’t get you , could you please describe or give me some example ? i use NOTE ++ so hope it wont have any empty space

https://documentation.storj.io/setup/cli/storage-node#running-the-storage-node

Check the template of the command. It has no new line for Windows. I don’t think its an issue but I wanted to rule that out.

Yes i copy from it in to NOTE ++ so no empty line now it have 10 lines same as doc

Could you show the notepad++ screen?

Could it be that the version you are running still requires the bandwidth parameter?

Try adding ‘-e BANDWIDTH="30TB" \’ before the ‘STORAGE=’ parameter.

YES here is … take look

Remove all the \ and get all the parameters in 1 single line instead of 10 lines. Copy + paste that on your putty screen.

Like this

docker run -d --restart unless-stopped --stop-timeout 300 -p 28967:28967 -p 127.0.0.1:14002:14002 -e WALLET=“0xXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX” -e EMAIL="user@example.com" -e ADDRESS=“domain.ddns.net:28967” -e STORAGE=“2TB” --mount type=bind,source="",destination=/app/identity --mount type=bind,source="",destination=/app/config --name storagenode storjlabs/storagenode:beta

Yes i did it … same error

I did try … same error

unknown flag: --mount
See ‘docker run --help’.