Update to 1.1.1

Hi,

How do you update the node, GUI window installer? Get the notification telling me to update, thought it would update after reboot, that didn’t work. I have no idea how to update it. Sorry if this as been pointed out before.

Thanks

1 Like

Hi

I run the node in Docker and also have a strange issue upgrading to 1.1.1. On the dashboard, after upgrading from “latest”, it states “Running the minimum allowed version 0.34.0”. I tried a fallback to “beta”, but the images appear to be the same, so there seems no way for me to force the software onto 1.1.1 completely.

What do to do?

Hi,

Same thing for me “Running the minimum allowed version 0.34.0” Read the FAQ’s and it says the GUI win install comes with auto update. It’s not working if this is the case.

I have no idea what to do lol.

Make sure you have storage update service running in Task Manager, tab “services”. It will update by itself.

So, in summary: neither Docker Watchtower, nor the Windows auto update are working as expected.
In my notifications view on the dashboard I also read the following right after I recreate the beta container from scratch (after wiping all cached images):

Update your Node to Version v1.1.1: It’s time to update your Node’s software, you are running outdated version v1.0.1

It’s clearly not doing that and I can’t work out why or how to get it to…

Cheers all

1 Like

Thanks, Yep it’s running.

I’ll just wait then.

1 Like

v1.1.1 not up yet for download ? keep getting messages to update, docker watchtower didnt update itself so i did manually and i get that my version is up to date … but still v1.0.1 (running ubuntu)

root@SERVER1:~# docker pull storjlabs/storagenode:beta
beta: Pulling from storjlabs/storagenode
Digest: sha256:10d50744ee9262970e5ebfb2d262078f9c691345207e68f4782ebc4c20eaa056
Status: Image is up to date for storjlabs/storagenode:beta
docker.io/storjlabs/storagenode:beta

I got the same message on both nodes no response to post in change log 1.1.1

i saw on github links are not ready ! i mean you must compile they didnt make install version for every system yet … probably we must wait … they didn’t finish yet

@sneakybrit
if you check your updater log you probably will see:
"New storagenode-updater version available but not rolled out to this nodeID yet "
It will come a bit later, as I saw the windows version comes in 1-2 day after the notice

2 Likes

don’t worry about having mismatched node versions, so long as you got the minimum version it will run fine and i’m sure it will be fixed to the correct version during the week.

somebody just made a minor oversight and because it’s a non critical issue, they aren’t paying attention…

Getting the notification as well… which is really unfortunate, because this is just going to lead to an unnecessary load of questions here on the forums and to support. And that’s just ignoring the people who don’t ask but still don’t know what to do.
image

It’s unfortunate because for most SNO’s this update simply isn’t available yet as mentioned in this post on the changelog topic.

The windows update will roll out gradually to all nodes over a week time, after which the Docker image will be published, which still can take up to three days to be picked up by your node. So for Docker nodes it can take up to 10 days total. So there is absolutely nothing to worry about here… it would be helpful if the dashboard didn’t tell people it’s time to update until it’s actually time to worry about manually updating. Or at least until the update is available to everyone.

6 Likes

maybe we can find a storjling that can actually kill the notification in the web dashboard…
that should in theory be a quick patch of ducttape to keep the forum from drowning…

I think we’ll have to deal with this in this cycle. The node needs to be updated to fix it. If it isn’t already adjusted in 1.1.1, we’ll have the same issue with the next update. Not much they can do about that.

1 Like

well if there is a rollout period what is the point to have notifications on the linux nodes that they should update if they cannot because the image is not on docker hub?

3 Likes

\ 40x40 Helene Unland (Storj)

Apr 4, 08:51 CST

Hello Jesus Gonzalez-Brey,
Thank you for contacting Storj. You can safely ignore those notifications for now. They are a leftover from earlier releases when we did not do slow rollouts to avoid all nodes updating at the same time. We have already alerted our SNO Growth team that they need to modify these alert messages so they don’t get posted prematurely to the SNO dashboard. Your nodes should update automatically when the new release gets pushed to them. Your windows node should receive the update first, and the docker node later, since we do not push updates to docker nodes until the deploy for windows GUI nodes is completed. The windows node(s) may also have trouble restarting automatically after it auto-updates (due to another issue with windows updater that our team is working on getting fixed). So you might have to manually restart the windows service for the storage node in that case.

Apologies for the inconvenience and unneccessary alarm this may have caused. I have let the team know that this should be fixed asap to avoid SNOs getting worried about manually updating their nodes when it is not necessary to do so.

Best regards,
Helene Unland
Storj Labs Support

7 Likes

Hello there,

i’ve just pulled storagenode from the beta tag (v1.1.1) and it’s still on v1.0.1 on my Raspberry Pi 4B with raspbian armv7l on board. It tells me it’s up to date. What’s the problem?

I’ve ran the manual update commands since I’ve received 3 notifications to move from v1.0.1 -> v1.1.1 and the watchtower hasn’t done it for me but the manual update just re-installs v1.0.1.

Do I need to use a different docker container now that we’re out of beta?

Hello @kosti11,
Welcome to the forum!

Docker version doesn’t pushed yet. Please, use the automatic updates: https://documentation.storj.io/setup/cli/software-updates#automatic-updates

Ah, so many others are having the same issue. It’s not just me. That’s “good”.