Uplink: Invalid access grant format shown

Ok, just started installing uplink on server. THe install went fine but when I try to do this
uplink access import main accessgrant.txt
I get this error
uplink: invalid access grant format

But I copied the txt file that was downloaded by creating access in first place.
Has something changed?

Welcome to the forum! Please follow these instructions where it is mentioned that you need to specify the path to the saved access grant in the uplink access command (~/Downloads/accessgrant.txt for example ).

I am in the root folder on linux so shouldn’t this work?
uplink access import main accessgrant.txt
I am cd to that folder
I have tried other but just says cant find file, this was does not say that but has error

Have you tried to include the full path? It would probably also be a good idea to move the accessgrant.txt file to a subdirectory first.

its in the root, would accessgrant.txt not be in root? I copied it to usr folder then tried this
uplink access import main usr/accessgrant.txt

I no little on linux, maybe root folder should be something else? …/ or /, not sure

If accessgrant.txt is now in the usr folder, then I think the following should work:

uplink access import main /usr/accessgrant.txt

Tried that, still no go

I can confirm, the new access grant saved as a file in the satellite UI cannot be imported to the latest uplink without modification - it contains the text access grant: before the access grant.

1 Like