Us2 beta with filezilla

Hello,

I have not been able to connect using Filezilla. I think the process need to be reviewed:

  • First time when I create an account, the information that it’s show it’s for programmers, not users like me, I only want to connect using Filezilla to just do backups.

  • When I found the Filezilla doc, it links to other docs not specifically for Filezilla and have images that aren’t as I can found now in the Tardigrade website, example:

  • I can’t find the route to the satellite I have to connect easily.
  • Too much keys and I cannot find the “API KEY” that Filezilla ask me.

15 minutes later, I still can’t connect to Tardigrade. If I was a customer, that was surely enough to leave the service.

2 Likes

Appreciate your response. It looks from your screenshot that you are testing US-Central-1 which is not the US2 Beta. Please see update steps below.

Quick steps

  1. Create Access Grant and copy the Token, this is used as the API Key in FileZilla
  2. Copy the Satellite Address, your address is at the end of that string, for us-central it will be as follows (us-central-1.tardigrade.io)
  3. Encryption passphrase, enter a passphrase (create this now)

image

We appreciate this feedback and will be updating our documentation today.

1 Like
Command: host us2.tardigrade.io:7777
Command: key *******************************************************************************************************************************************************************************************************************************************************************************************************************
Error: Could not connect to server

Please see the updated documentation for our production Satellites and FileZilla. Do note that only FileZilla pro will work with the US2 Beta at this time. This will be addressed in a future FileZilla update.

https://documentation.tardigrade.io/how-tos/set-up-filezilla-for-decentralized-file-transfer

Filezilla Pro doesn’t work either, even using the S3 connector
Screenshot 2021-03-11 at 20.21.00

I have it working but had to edit the s3 providers under settings. I had to then delete the site from site manager and recreate. I’ll writeup instructions asap.

image

Looks like you just need to omit the port.

Hmmm… interesting, didn’t work for me

Status: Retrieving directory listing…
Status: Resolving address of gateway.tardigradeshare.io
Status: Connecting to 167.233.15.115:443…
Status: Connection established, initializing TLS…
Status: Verifying certificate…
Status: TLS connection established, sending HTTP request
Command: GET / HTTP/1.1
Command: Authorization: ********************************************************************************************************************************************************************************************************************************************
Command: Connection: keep-alive
Command: Host: gateway.tardigradeshare.io:443
Command: Keep-Alive: 300
Command: User-Agent: FileZilla/3.52.2
Command: x-amz-content-sha256: e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
Command: x-amz-date: 20210311T215528Z
Response: HTTP/1.1 403 Forbidden
Response: Accept-Ranges: bytes
Response: Content-Length: 243
Response: Content-Security-Policy: block-all-mixed-content
Response: Content-Type: application/xml
Response: Server: MinIO
Response: Vary: Origin
Response: X-Amz-Request-Id: 166B6871B3BEE3D3
Response: X-Xss-Protection: 1; mode=block
Response: Date: Thu, 11 Mar 2021 21:55:28 GMT
Error: Please verify the user name and password used to connect.
Error: Failed to retrieve directory listing

Might be something to do with the providers, as you said. How did you change those?

Hope this helps!

1 Like

I’d already done that in order to access the Vortex platform (which is working fine, btw).
Still no joy with US2. I must be doing something really stupid, I’m sorry :frowning:

Thank you, that worked for me.

1 Like

Why is my interface different?

Source: Set up FileZilla for Decentralized File Transfer - Tardigrade

There is a new Filezilla version but still the same error.
This Filezilla integration seems to be laughable and not serious.

Filezilla FREE works with standard paid for satellites using the Tardigrade connector

Filezilla PRO ($15) works with us2-Beta using the S3 connector. I have tested.

Once you have setup the free Beta account online. Add the settings to Filezilla PRO

Add a new S3 connector and setup as

image

Once setup you will need to create a bucket using uplink.exe command line tool Set Up Uplink CLI with Access Grant - Tardigrade

I see the update reflected in the release notes and the new option in the menu. Seems the issue is only the Pro version got the fix. Thank you for reporting.

Release Notes FileZilla Pro 3.53.0

Menu

How is this supposed to be a serious integration?

3.53.0 (Free Version) has tested as working with access grant support. From the release notes it looks like the free version got the update on the 15th.

1 Like

@Dominick

As you know big files creates problems over Rclone. My 100gb files though start directly with the new filezilla free version :wink:

2 Likes

Thanks for the hint. Finally I get it working with the free version as well after I have completely removed and reinstalled.

For testing to me it looks like major feature like multipart and resume of up- and downloads has not been implemented into Filezilla yet. Is this feature already working on that satellite or when is implementation to expect?

My results so far: I was able to upload 2 files without issues, first one almost 1 GB, second one 6 GB. The third file I was not able to upload with around 33 GB. The upload kept restarting and at one point finally dies. Which is odd as when I can succesfully upload a 6 GB file then I should be able to upload a 33 GB file as well.