W10 - This app cant run on your pc - During sign the identity

I am at the point of signing my single use auth token, including the entire string > than 36.

I have never seen this before, but i tried to execute cmd.exe as an administrator following the instructions from https://documentation.storj.io/dependencies/identity and i keep getting the GUI error “This app can’t run on your PC”.

Ive disabled as much as i could from a winblows security standpoint but finding im still unable to execute identity_windows_amd64.exe authorize storagenode tokenemail+string and its not even wanting to execute the .exe - Anyone else run into these troubles. I even created an administrator account and got the same issues.

Many thanks for your time.


Have you tried these steps ?


Hello @smeg,
Welcome to the forum!

Please, make sure that your Windows is 64 bit, 32 bit doesn’t supported


Yup - 64bit - Check

Tried most of those. Ill explore further tomorrow, but being a systems admin for a while this is super strange to me. It just wont execute even as an admin.

It doesnt matter what director i run it from, it just keeps throwing this same error. Yet i am executing as an admin

It doesn’t required the admin rights.
Try unblock the executable:

  1. Navigate to the folder where you downloaded a binary
  2. Open a Powershell here as a regular user
Expand-Archive .\identity_windows_amd64.exe.zip . -Force
Unblock-File .\identity_windows_amd64.exe

And then try to create an identity

I have created an identity - Its signing the identity where i am stuck. the following is e:\storj


It requires access to the internet. Please, allow access for this application in the Windows Defender or your firewall/antivirus

Please, unpack the identity again, it can’t be 0 size

Also, if you moved the generated identity from the default folder, you must specify a new path with the parameter --config-dir.

.\identity_windows_amd64.exe authorize storj <auth-token> --config-dir e:\
1 Like

Yup you are right. Was a write issue that the executable was not writing to the directory and was 0kb. Total oversight. Thank you. Managed to execute. Now to do the rest!

1 Like

When you are all set maybe you can show off your Storj node here