Windows and Docker together


I’ve just made the switch from CLI to Windows GUI which works fine. I was wondering, since I have another 8TB hard drive unused, can I start another node (with a new token) on docker while at the same time run the first one on windows?
If not, is there a better way of running two nodes?
My computer is powerful enough and my illimited connexion can handle it too.


1 Like

Make sure that you have specified the storage folder with your data from the CLI setup, otherwise your node will start from scratch and will be disqualified for too many failed audits.

You can run a second node in the docker, just use a different external port for port mapping and ADDRESS option.
Don’t forget to generate a new identity, do not use a clone.


thanks Alexey :heart_eyes:

1 Like

You can even start second GUI node also, on same windows.

Can I? Just by doing the same procedure as before except with new ports and new hard drive?

no, you need install service by hand.

Thanks! When I create my second identity, it wont erase my first one since it might appear in the same folder? I can move it somewhere else after?

do you use indentity folder that was automaticly created?
I use as mension in my other post, for every new node new map on C:\ indentity,1,2,3…

The name storagenode you use in the command determines the folder name. Just use storagenode2 in the command. But regardless it’s probably a good idea to not keep the identity in that default location.

Well it turns out for some reason I cant open any port on my router anymore so… my full node that ive been running for more than 6 months is dead now…by the time I fix it its gonna be too late… goodbye storj

What do you mean? Can you login to the router? Can you create a port forwarding rule? Is the WAN IP different from the ?

Of course, the rule is created. its been working for months and now for some reason I cant explain the port is showing as closed when I check. I created it again but to no avail. Yet it appears on the list of opened ports on mu router…

I think problem in some other place.
Do you use DDNS ot Static IP.
May be your pc in locan network got other ip for sime reason?
Windows 10 firewall again acctive after windows update?
If ip is static may be your provider changed your external IP?

Sounds like your ISP is placed you behind their NAT. Please, login to the router, switch to the status page and write down your WAN IP.
Then go to the and compare the written WAN IP with IP there. If they do not match, then you have exactly this problem.
To solve it you have a few options:

  • switch the ISP to the one who give you a public IP;
  • talk with your current ISP and ask how you can obtain a public IP, it could be dynamic, but must be a public (your WAN IP will be the same as on yougetsignal);
  • use a VPN with a port forwarding option, such as PIA,, ngrok, purevpn, etc.

My ip stayed the same… ive disabled the windows firewalls and created a new exception just in case… nothing works…

Could it be possible that your ISP has restricted your bandwidth/internet usage? Do you have a bandwidth cap?

what is your external ip?

I’m talking about the WAN IP, not the public IP. Make sure your router has the same WAN IP as your public IP


for a reason I dont understand my node is back online and working… but it has been offline for the last 6 days while I fix the issue… does that mean I am out of the game after months of good service? Can an admin check or make sure Im not disqualified…? 12bWGqvj4MnimWNK7tiXXdYxAErWKgWgcS2UALphz6PG5acWxGC


You can figure out it yourself either on dashboard http://localhost:14003 (or what port you have mapped) or via API: Script for Audits stat by satellites