Zksync restarting docker fails

Trying to restart my docker node with the opt in but fails now and i cant seem to start it at all: I get this generic fail message no matter what i try now.

docker: invalid reference format: repository name must be lowercase.

Here is my docker command

sudo docker run -d --restart unless-stopped --stop-timeout 300
-p 28967:28967
-p 127.0.0.1:14002:14002
-e WALLET= xxx
-e EMAIL=xxx
-e ADDRESS:28967=xxx.xxx.me
-e STORAGE=10.9TB
-e operator.wallet-features: [“zksync”]
–mount type=bind,source=/home/jjj/.local/share/storj/identity/storagenode,destination=/app/identity
–mount type=bind,source=/mnt/md0/,destination=/app/config
–name storagenode storjlabs/storagenode:latest

1 Like

error was a space after the wallet = sign :frowning:

1 Like

Is this the right syntax? This is what needs to be added to the config file (-e excluded).
For adding the option to the command directly I think it would look more like:
–operator.wallet-features=’[“zksync”]’

EDIT: According to one of @Alexey’s post, it should be:

--operator.wallet-features=zksync

…to be put after storjlabs/storagenode:latest

Disclaimer: Untested code! :sweat_smile:

2 Likes

You need to specify this option in the config.yaml, not in the command.
If you want to specify it in the command, then @Pac is right

3 Likes

Update:
The option should be -operator.wallet-features=zksync

1 Like

Ah okay, thanks @Alexey :+1:
Fixed my post.

Out of curiosity, if the array syntax is not availble when passing options to the command directly, how would you set a list of wallet features here? A coma separated list, like below maybe?

--operator.wallet-features=zksync,dummyfeature

using the following seems to let the system start (only using -o... caused it to not start and give a list of options)

services:
    storagenode:
        image: storjlabs/storagenode:latest
        container_name: storagenode0
        hostname: storagenode0
        restart: unless-stopped
        command: "--operator.wallet-features=zksync"

is there any way I can confirm it’s configured properly?

edit: seems like this is on the wrong topic, can it be moved or is it fine?

It should work. What is it complaining?
For honestly I uses the docker-compose too, but I simply added string to my config.yaml files. They will be there anyway, since I redirected logs. I didn’t want to spend time to check it with only options.