Can't create new bucket with access grant or api key

Hello,

i’m a new user and i’m trying out storj and uplink under windows. The uplink version is:

Release build
Version: v1.22.2
Build timestamp: 11 Feb 21 03:36 CET
Git commit: 3948c0e258c339fb5e9f58c3baea9bc04ebfdd29

I first created an access grant with the web interface, put it into a text file and tried importing it in uplink:

E:\Backup\bin>uplink.exe import accessgrant.txt
default access imported.

Then i’m trying to create a bucket, which fails:

E:\Backup\bin>uplink.exe mb sj://backup_test
Error: uplink: permission denied (bucket: metainfo error: Unauthorized API credentials)

In my second attempt (after reading here in the forum) i tried creating an access grant with the cli tool, but the documentation is not matching with the web frontend:


There is no link “API Key” in the sidebar.

But then i found the link ‘Create Access Grant in CLI’ in the ‘access grant’ wizard, which displays a satellite address and a token (token = api key?). I tried uplink.exe setup, put in the satellite address, my api key/token, chose a name and an encryption key, but then it says:

Error: uplink: permission denied (Unauthorized API credentials); unable to unmarshal access grant: proto: pb.Scope: illegal tag 0 (wire type 2)

So at the moment, i’m a bit lost.

I appreciate any help.

There is a known bug with the browser cache. Can you please generate a new access grant in the browser but empty the browser cache or hard refresh the page before you do so? That usually fixes it.

The issue is same as Uplink set up: Unauthorized API credentials

the documentation is not matching with the web frontend:

Exactly: Gateway set up: Unauthorized API credentials

Updating https://documentation.tardigrade.io/api-reference/s3-gateway is necessary for sure. The word API should be removed altogether so there is not a chance of confusion.

@littleskunk Mind sharing where the bug is discussed on GitHub?

We are using Jira and I think you can’t look into the tickets.

I thought about this one: https://github.com/storj/tardigrade.io because the bug exists at tardigrade.io. Do we have something that is not open but related to tardigrade.io ?

Thanks, i tried it again and this time it worked.

2 Likes

Hello @hberg539,
Welcome to the forum!

You used a deprecated section for some reason, of course it’s not match the current state.
If you search for the access grant, compatible with deprecated API keys, you can use this wizard: https://documentation.tardigrade.io/getting-started/generate-access-grants-and-tokens/generate-a-token
But you need to use the interactive uplink setup CLI wizard to use this token as an API key.