My Node does not start properly

Hi mates,

I think that I’ve done everything properly. However my node is not working properly maybe I need another pair of eyes.

I set up the storage node however when I am trying to run the docker image the status is restarting

I already did this
docker stop -t 300 storagenode
docker rm storagenode
docker pull storjlabs/storagenode:latest

and rerun the image with my info
docker run -d --restart unless-stopped --stop-timeout 300 \

-p 28967:28967 \

-p \

-e WALLET=0xE26b4761DD50CfE22D8eF632bc229d17D09DF5B8 \

-e \

-e \ (I didnt share my dns for privacy purposes)


–mount type=bind,source=/home/edu/.local/share/storj/identity/storagenode,destination=/app/identity \

–mount type=bind,source=/mnt/hd1/,destination=/app/config \

–name storagenode storjlabs/storagenode:latest

Does anybody have an idea? I dd

Please try it: docker logs -t storagenode --tail 100 -f for determining the root cause.

1 Like

Should be -e

1 Like

That’s a weird quirk caused by the forum if you don’t put it in a code block. The original post was likely correct.

Which original post ?

just try typing that correct line without a code block, the forum will turn it into the wrong one.

1 Like

Thanks that’s a good catch I actually had -e
I dont know why I copied wrong here in the blog
however I will keep trying and run the log as suggested

Thanks I will double check everything again.

1 Like

Well finally I got the logs it might be something with my noip Address which I already try with the IP or my the path in my pc.

If you have a ARM64 device and 64 bit OS, then try this workaround:

However after the next version with fix would be published you will need to pull the right image with the latest tag and replace the image in the docker run command.

1 Like

Thanks I will try and keep you posted!

Hi Alexey - I just tried and I got this in the logs
$ sudo docker logs -t storagenode --tail 100 -f
2020-12-23T14:03:12.479116442Z error during connect: Post http://docker:2375/v1.24/images/create?fromImage=storjlabs%2Fstoragenode&tag=2413a9a0d-v1.18.1-go1.15.5-arm32v6: dial tcp: lookup docker on no such host

I will try to do see if this might work on this case

By the way I have ARM64 and the 64 bit OS.

Please, show your full docker run command, you can remove any personal data.
Please use a new line with three backticks (```) before the command and the new line with three backticks after the command for the nice formatting.

Hi Alexei - Thanks for the tip about the formatting, please the docker command that I used

sudo docker run -d --restart unless-stopped --stop-timeout 300 \
 -p 28967:28967 \
 -p \
 -e WALLET=0xE26b4761DD50CfE22D8eF632bc229d17D09DF5B8 \
 -e EMAIL = \
 -e \
 -e STORAGE = 6TB \
 --mount type=bind,source=/home/edu/.local/share/storj/identity/storagenode,destination=/app/identity \
 --mount type=bind,source=/mnt/hd1/,destination=/app/config \
 --name storagenode docker pull storjlabs/storagenode:2413a9a0d-v1.18.1-go1.15.5-arm32v6 

The image name should not include docker pull :slight_smile:
You also should remove spaces between variable names and equation mark, the same goes for the values.

P.S. I edited your post to show, how the formatting should looks like.

1 Like

Thanks Alexey - looks like that was the main problem
Right now the image is running but I got the following error:
edu@edu-desktop:~$ sudo docker logs -t storagenode --tail 100 -f
2020-12-23T19:59:55.165509107Z 2020-12-23T19:59:55.165Z INFO Configuration loaded {"Location": "/app/config/config.yaml"}
2020-12-23T19:59:55.175724940Z 2020-12-23T19:59:55.168Z INFO Operator email {"Address": ""}
2020-12-23T19:59:55.175778958Z 2020-12-23T19:59:55.168Z INFO Operator wallet {"Address": "0xE26b4761DD50CfE22D8eF632bc229d17D09DF5B8"}
2020-12-23T19:59:55.809564097Z 2020-12-23T19:59:55.809Z INFO Telemetry enabled {"instance ID": "17rUiCzph4fnAGUWwCuUaidxU4o2xGBtnvTyWzwfEbSiQ3Wk8B"}
2020-12-23T19:59:55.869126464Z 2020-12-23T19:59:55.868Z INFO db.migration Database Version {"version": 46}
2020-12-23T19:59:56.872495556Z 2020-12-23T19:59:56.872Z INFO preflight:localtime start checking local system clock with trusted satellites' system clock.
2020-12-23T19:59:57.558364030Z 2020-12-23T19:59:57.557Z INFO preflight:localtime local system clock is in sync with trusted satellites' system clock.
2020-12-23T19:59:57.559114244Z 2020-12-23T19:59:57.558Z INFO bandwidth Performing bandwidth usage rollups
2020-12-23T19:59:57.559548980Z 2020-12-23T19:59:57.559Z INFO Node 17rUiCzph4fnAGUWwCuUaidxU4o2xGBtnvTyWzwfEbSiQ3Wk8B started
2020-12-23T19:59:57.559610627Z 2020-12-23T19:59:57.559Z INFO Public server started on [::]:28967
2020-12-23T19:59:57.559941698Z 2020-12-23T19:59:57.559Z INFO Private server started on
2020-12-23T19:59:57.562292154Z 2020-12-23T19:59:57.558Z INFO trust Scheduling next refresh {"after": "5h22m48.494741911s"}
2020-12-23T20:00:17.750146882Z 2020-12-23T20:00:17.748Z ERROR contact:service ping satellite failed {"Satellite ID": "12EayRS2V1kEsWESU9QMRseFhdxYxKicsiFmxrsLZHeLUtdps3S", "attempts": 1, "error": "ping satellite error: failed to dial storage node (ID: 17rUiCzph4fnAGUWwCuUaidxU4o2xGBtnvTyWzwfEbSiQ3Wk8B) at address rpc: dial tcp 19x.16x.x.1x:28967: i/o timeout", "errorVerbose": "ping satellite error: failed to dial storage node (ID: 17rUiCzph4fnAGUWwCuUaidxU4o2xGBtnvTyWzwfEbSiQ3Wk8B) at address rpc: dial tcp x.x.3x9.x:28967: i/o timeout\n\*Service).pingSatelliteOnce:141\n\*Service).pingSatellite:95\n\*Chore).updateCycles.func1:87\n\*Cycle).Run:92\n\*Cycle).Start.func1:71\n\*Group).Go.func1:57"}

Your external address is not available from outside.
Make sure that you updated it to your actual public IP (replace to your actual address):


The actual public IP you can see there:
Also, make sure that WAN IP on the main page of your router is match that public IP, otherwise port forwarding will not work.

1 Like

Hi @Alexey thanks for the tip I will double check :white_check_mark: that

1 Like

Hi Alexey - Thanks for your patience and all your tips.
I think that I found the solution my ip was fine but you are not going to believe it I don’t know why I didn’t start the NoIP Client. So I went back and launched and now I got this in the dashboard
I really hope everything is ok :grinning:
Once again thank you very much.

Storage Node Dashboard ( Node Version: v1.18.1 )


ID xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxQ3Wk8B
Uptime 18m12s

               Available         Used     Egress      Ingress
 Bandwidth           N/A     29.87 MB        0 B     29.87 MB (since Dec 1)
      Disk       6.00 TB     26.25 MB



Hi @Alexey - I have a question related to the image that I am using storjlabs/storagenode:2413a9a0d-v1.18.1-go1.15.5-arm32v6

I believe there is no problem setting up the automatic updates for the ARM32 Docker image?
Please correct me if I am wrong.

Thanks in advance and happy holidays!