QUIC Misconfigured on a Qnap TS-431P3 device

Hi, everyone,

I’ve been running a node on a Qnap TS-431P3 for a year.
Recently, “QUIC Misconfigured” appears on the dashboard.

Which commands do I enter via ssh to release the UDP port?

I’ve already done it on the Fritzbox router.

Thanks in advance

Do you use a QNAP app or pure docker?
If the pure docker, then you need to update your docker run command to include udp port mapping, i.e. -p 28967:28967/tcp -p 28967:28967/udp, as specified in the documentation.
You also need to update your port forwarding rules on your router either to add UDP alongside with TCP to the existing one or create another rule specifically for UDP.

If you use a QNAP app, then I believe it’s not possible, the port mapping is hardcoded in this wrapper around docker.

Hello Alexey,

I entered the following command and got this error message.

sudo docker run -d --restart unless-stopped --stop-timeout 300 \

-p 28967:28967/tcp
-p 28967:28967/udp
-p 127.0.0.1:14002:14002
-e WALLET=“0xb99f33c6c4BFf4C67448"
-e EMAIL="luc
mx.
"
-e ADDRESS="
*********.myfritz.net:28967”
-e STORAGE=“6TB”
<rce="/share/Storj/Identity/storagenode",destination=/app/identity
<rce="/share/Public/speicher",destination=/app/config
–name storagenode storjlabs/storagenode:latest
docker: Error response from daemon: Conflict. The container name “/storagenode” is already in use by container “c680b7a66ae3401e917e452ae98017d988d00cad97b15a6c 1aa9d521a308e33e”. You have to remove (or rename) that container to be able to r euse that name.
See ‘docker run --help’.

What can I do there?

Are you using a QNAP app or just Docker?

To answer the question. I use the pure docker.
I have now added a UDP rule to the router. I also checked the ports.

Now the command has been executed but now another container has been created. Actually, I wanted to configure my existing container in such a way that the UDP protocol is also used…wouldn’t the “exec” command make more sense than the “run” command that creates a new container?

Another theoretical question:

What happens if I delete the container of my existing node (1 year term)? Is all data then gone in the node that was collected over 1 year? Or is that even the way to the goal?

Hi @Luckymaster

why do you use the sudo command if you have a node in the docker? I have a Qnap arm and these are my commands:

  • Download the latest version first

docker pull storjlabs/storagenode:latest

  • Then you tell him where the folders are
docker run --rm -e SETUP="true"
--mount type=bind,source="/share/storj01/identity/storagenode",destination=/app/identity
--mount type=bind,source="/share/storj01/storage",destination=/app/config
--name storagenode storjlabs/storagenode:latest
  • Then you give it the command to start it with your data
docker run -d --restart unless-stopped --stop-timeout 300 \
-p 28967:28967/tcp \
-p 28967:28967/udp \
-p 14002:14002 \
-e WALLET="0xXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX" \
-e EMAIL="user@example.com" \
-e ADDRESS="yourdomain.ddns.net:28967" \
-e STORAGE="2TB" \
--mount type=bind,source="/share/storj01/identity/storagenode",destination=/app/identity \
--mount type=bind,source="/share/storj01/storage",destination=/app/config \
--name storagenode storjlabs/storagenode

Nothing happens, indeed it is the way to update. Stop the storagenode docker, then throw it, download a new version and give the command to create it again, with the same settings

docker stop -t 300 storagenode

docker rm storagenode

docker pull storjlabs/storagenode:latest

docker run -d --restart unless-stopped --stop-timeout 300
-p 28967:28967/tcp
-p 28967:28967/udp
-p 14002:14002
-e WALLET=“0xXXXXXXXXXXXXXXXXX”
-e EMAIL="user@example.com"
-e ADDRESS=“yourdomain.ddns.net:28967
-e STORAGE=“2TB”
–mount type=bind,source="/share/storj01/identity/storagenode",destination=/app/identity
–mount type=bind,source="/share/storj01/storage",destination=/app/config
–name storagenode storjlabs/storagenode

@Roberto
This command should not be performed more than once. If the node already worked, this command can destroy your node, be careful.

This is because you did not remove a previous container. If you used QNAP App before, and you now want to use pure docker, then this app should be removed first (it’s recommended to write down paths to data and identity, they will be needed in the docker run command).
If you tried to run the docker version of storagenode, you should stop and remove the container before try to run it again.

Well analyzed Alexey,

I deleted the app. Apparently that’s why I’ve had and still have so many problems.

I now have a container that is running. But the dashbard doesn’t work. Now I have no control whether my node is really running or whether something else has created it.

No idea.

docker ps -a
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
e241f5bed447 storjlabs/storagenode:latest “/entrypoint” 6 minutes ago Up 5 minutes 127.0.0.1:14002->14002/tcp, 0.0.0.0:28967->28967/tcp, 0.0.0.0:28967->28967/udp storagenode

Your node is working, it’s just available only from the QNAP itself only.
You can use either https://docs.storj.io/node/resources/faq/how-to-remote-access-the-web-dashboard or remove 127.0.0.1: from the port mapping for dashboard port 14002 (i.e. -p 14002:14002), it will allow you to connect to the web dashboard from your local network by IP of your QNAP on port 14002.
Please, do not publish this port on your router, you will publish your private information to the internet.
Use either https://docs.storj.io/node/resources/faq/how-to-remote-access-the-web-dashboard or [Tech Preview] Multinode Dashboard Binaries to remotely access your dashboard.

SSH is already installed. That’s how I enter the commands

The next problem:

I enter these commands via Putty:

@192.168.3.'s password:
[@TS-43* ~]$ ssh -L 14002:localhost:14002 @TS-43
@ts-43* password:
bind [::1]:14002: Cannot assign requested address
channel_setup_fwd_listener_tcpip: cannot listen to port: 14002
Could not request local forwarding.

Sie müssen diesen Befehl nicht auf QNAP, sondern auf Windows ausführen. Allerdings ist es dann besser, nicht PuTTY, sondern einen nativen OpenSSH-Client zu verwenden, siehe Get started with OpenSSH | Microsoft Docs

You need to run this command not on QNAP, but on Windows. However, it is better then to use not PuTTY, but a native OpenSSH client, see Get started with OpenSSH | Microsoft Docs

Yes, in fact after I did not enter it, I thought I was clear

This tell me, that you login to somewhere (probably to TS-43) then you have tried to port forward 14002 to itself. This will not work :slight_smile:

You need to execute

ssh -L 14002:localhost:14002 user@TS-43

right in the PowerShell/cmd.exe

Since I don’t have a browser on the Qnap, I can’t access the dashboard on the Qnap. I didn’t find any either (app center).
I installed the SSL Client on my Windows 11 PC. Where does the server need to be installed? On my Winsows PC or on the Qnap? Do I need a server at all, since I also came to the web interface before (with the Storj APP).

You need to install SSH on your PC and log into the Nas via the SSH program. On the nas, on network services, you need to enable SSH.

Yes, I did the same but unfortunately it doesn’t work. Any ideas?

To see the dashboard from the PC you have to remove 127 from your command. To do this you have to stop the node, remove it, update it and give the command again without 127

-p 28967:28967/tcp
-p 28967:28967/udp
-p 14002:14002
-e WALLET=“0xb99f33 c6c4BFf4C67448"

it’s like doing an update via ssh

Then on the PC browser write the IP of the NAS plus: 14002

3