QUIC Misconfigured on Synology

I have now tried several times and I have the same issue with my synology docker node.

  • Port mapping on router correctly set
  • Started node with tcp and udp port
  • No firewalls active on my synology
  • Node runs newest version (v1.49.5)
  • Restarted node several times
  • Still says: QUIC Misconfigured

Any hints?

1 Like

Hi @lenidope
Please can you post your new docker run command with the tcp and udp ports listed.

Hey @Stob
Thanks for your answer. My Command:

sudo docker run -d --restart unless-stopped --stop-timeout 300 \
    -p 28967:28967/tcp \
    -p 28967:28967/udp \
    -p 14002:14002 \
    -e WALLET="……………………" \
    -e EMAIL="……………………" \
    -e ADDRESS="………:28967" \
    -e STORAGE="3TB" \
    --mount type=bind,source=…,destination=/app/identity \
    --mount type=bind,source=…,destination=/app/config \
    --sysctl net.core.rmem_max=4194304 \
    --name storagenode storjlabs/storagenode:latest

Router Config:

I have a test node on DSM 7 and QUIC works fine.
You need to set “rmem_max” when starting DSM, not in “docker run”

sysctl -w net.core.rmem_max=2500000

and restart DSM (your Synology)
and stop, rm, start your SN



You are GREAT! This works, thank you a lot!

1 Like

You’re welcome, best regards
I am asking for one thing - when you know something - help others


4 posts were split to a new topic: Node on Synology is offline and has QUIC misconfigured

Hi there,

I have same issue with DSM 7 after last DSM update. Tried everything also with Alexey and guys but nothing helped. What this task do if I can ask?

Thank you


QUIC is the preferred protocol the network communicates on. It’s a little faster with less overhead. But if it’s not available the communication with your node will fall back to TCP. It’ll function just fine using that fallback, but you might be slightly slower than other nodes, causing you to be part of long tail cancellation slightly more often. So far I haven’t really seen any indication that this makes a very big difference on the node end. It’s definitely better to have QUIC, but no reason to lose sleep over if it doesn’t work. (At least not for now)

This fixed QUIC issue for you?

I have similar issue but nothing help. Tried your scheduled task and reboot DSM but still same issue described in my thread:


Should I recreate nodes under docker as well?

Thank you


Yes, it always worked, now I don’t have a node anymore (I now spend less on electricity than I earned)
Yes, the container must be started from the beginning, not just restarted

docker stop -t 300 containername
docker rm containername
docker run.......

Hi Peem,

I have created scheduled task:

Rebooted SYNOLOGY DSM itself.

Removed NODE and created new one:

Unfortunately did not help:

There is not issue with routing or network issue as that was troubleshooted within my mentioned thread. Node on my Windows 10 PC behind the same router works perfectly same as VM Win10 on the same SYNOLOGY behind the same router. :frowning:


Log in via SSH to your NAS and enter the command result:

sysctl net.core.rmem_max

SSH output:

xxxxxxxxx@SYNOLOGY:/$ sysctl net.core.rmem_max
net.core.rmem_max = 2500000

Well that’s correct …
Show the ‘docker run’ command you are giving

This is how I have created every new node under Docker container:

 sudo docker run -d --restart unless-stopped --stop-timeout 300 \
-p 28967:28967/tcp \
-p 28967:28967/udp \
-p 14001:14002 \
-e WALLET="xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx" \
-e EMAIL="tomxxxxxxxxa@xxxxxx.com" \
-e ADDRESS="xxxxxxxxxxxx:28967" \
-e STORAGE="10TB" \
--mount type=bind,source="/volume3/STORJ_01/Identity/storagenode",destination=/app/identity \
--mount type=bind,source="/volume3/STORJ_01",destination=/app/config \
--name STORJ_01 storjlabs/storagenode:latest

Everything is fine …
and it doesn’t work …
maybe a firewall …

Analysis of the node log may indicate some errors in the QUIC configuration

Firewal is disabled on my SYNOLOGY DSM.

From network point of view we have troubleshoot and tried everything as it is described here:

Quic stop working after Synology DSM update

I have also changed wi-fi router, recreate many times nodes and strange is that before DSM update works QUIC properly also from SYNOLOGY - DOCKER nodes. Now only from W10 machines. Something scrubbed after that update.

This is error after fresh start of the NODE:

NODE is online and operates normally only QUIC is issue for some reason.

There are allowed both UDP and TCP on the router:


Contacted SYNOLOGY and DOCKER support but not relevant answers or no answers at all.

Log: this is exactly how it behaves when you connect via VPN where it only routes TCP

Node as VM Win10 on this Synology works fine? If yes then Docker is the suspect… maybe to check downgrading the Docker version will help…