Remote dashboard not working

The guide for Linux: https://documentation.storj.io/setup/cli

his is for docker container im not interesting in his guide

official still shows coming soon

Ah, you want a “GUI” version?
You can get it now:

thank you finally i can run my server for storj

Hello Allexey,
I have a similar problem.
I just finished installing a new node on a linux VM because I wanted to test how things work with Docker. Everything works normally at the moment. I am able to see the dashboard, butonly with a command:
docker exec -it storagenode /app/dashboard.sh

I have executed docker with the followin command:
docker run -d --restart unless-stopped --stop-timeout 300
-p 28968:28968
-p 14004:14004 \

And currently I am expectinig to be able to open the dashboard on any browser on any of my PC in my local network. However, this does not happen.
image
I don’t see any related errors in the log file.
Can you please assist me to find te problem? I am looking forward to deploy several docker nodes on a new PC utilizing 5 6 hdds, but first want to test on this VM so that I prepare for all the roadblocks that I will probably face.

Thank you in advance!

BR,
Niki

When you run

docker exec -it storagenode /app/dashboard.sh

does it show ONLINE or OFFLINE? Unless you’ve changed the config.yml file from its default ports, the port forwards in your command should be as follows

...
-p 28968:28967 \
-p 14004:14002 \
...
1 Like

As I wrote, everything is working normally. The node is Online:

Status ONLINE
Uptime 1h16m11s

               Available          Used      Egress       Ingress
 Bandwidth           N/A     305.10 MB     0.71 MB     304.39 MB (since Jan 1)
      Disk     509.71 GB     293.81 MB

Internal 127.0.0.1:7778

The problem is only in the dashboard interface using the browser.
One question, why do you want the server ports to be in a range? I wanted a specific port 28968 and put that specific port as I have wrote above in the command that I use:

docker run -d --restart unless-stopped --stop-timeout 300
-p 28968:28968
-p 14004:14004 \

To me it seems that the linux itself can not see the opened port. I made this test:

[root@localhost ~]telnet 192.168.2.128 14004
Trying 192.168.2.128…
telnet: connect to address 192.168.2.128: Connection refused
[root@localhost ~]# telnet 127.0.0.1 14004
Trying 127.0.0.1…
Connected to 127.0.0.1.
Escape character is ‘^]’.
Connection closed by foreign host.
[root@localhost ~]#

As you can see the port is opened on the localhost but not on the IP. Can I somehow route it ? I tried modifing the hosts file to look like this but this did not help:

127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4
192.168.2.128 localhost localhost.localdomain localhost4 localhost4.localdomain4
127.0.0.1 192.168.2.128
::1 localhost localhost.localdomain localhost6 localhost6.localdomain6

I am new to linux so please excuse me if I don’t sound professional enough.

BR,
Niki

You need to change your docker run command as per fmoledina’s post above. The docker -p option syntax is:
-p <external OS port>:<internal container port>

The storagenode software inside the container uses ports 28967 and 14002 for connection to the network and dashboard respectively, unless you intentionally change it via the config.yaml file.

I’m not sure what you did to your hosts file, but it shouldn’t be necessary and I would change it back to its default state to avoid compounding problems when troubleshooting (unless you really know what you are doing with the hosts file).

Hi
where did you get that information from? I was looking at these 2 links:

https://documentation.storj.io/setup/cli/storage-node

Please send me a link.

BR,
Niki

To be honest I just know this due to having been involved with the project/running nodes for a long time. I cannot point you to any official documentation regarding this configuration, but I can link a post from a Storj employee who describes it.


You can read more about how the -p option with docker run here:

It says so right in the documentation that you’ve linked.

I hope you understand the -p notation for Docker. The left side port is on the host and that will forward to the right side port which is in the container. Unless you’ve changed the storagenode config.yml it is highly likely the the right side of these port definitions should be left unchanged. You’re free to use whatever port you need to on the left side.

What is the output of docker ps -a | grep storjlabs? We’d be able to understand what ports are being exposed by the container and help you forward them appropriately from the host.

As a side note, instead of the above I’d suggest -p 127.0.0.1:14004:14002.

The 127.0.0.1 makes sure the dashboard cannot be accessed from the Internet.


And this should be -p 28968:28967, as outlined by @fmoledina.

Thank you very much guys!!!
I have never workered with docker before and I think I saw my mistake.
I will test today and let you know if it got fixed.

BR,
Niki

Great guys it worked:

After you explained it to me, I configured it and as you can see it works perfectly.

Thank you very much!

BR,
Niki

3 Likes