SNO Board not working due to untrusted satellite

That’s the problem I reported here too: SNO Board not working due to untrusted satellite

Thanks for the reply, I should have said I tried the Web dashboard on multiple devices and got the same. I just tried to refresh the cache anyway and it didn’t solve it.

I seem to have this problem too…

One of my nodes did this after a quick restart it worked fine.

Updates

This issue is already being addressed and the fix will be in place before removing stefan-benten from trusted satellites.

6 Likes

this began yesterday and it doesn’t appear to correct it self, storjnet.info reports this satellite as down uptime robot reports it’s online am I the only one with tis error,2020-09-17T12:24:05.412Z ERROR contact:service ping satellite failed {“Satellite ID”: “118UWpMCHzs6CvSgWd9BfFVjw5K9pZbJjkfZJexMtSkmKxvvAW”, “attempts”: 9, “error”: “ping satellite error: rpccompat: dial tcp 78.94.240.189:7777: connect: connection refused”, “errorVerbose”: “ping satellite error: rpccompat: dial tcp 78.94.240.189:7777: connect: connection refused\n\tstorj.io/common/rpc.Dialer.dialTransport:211\n\tstorj.io/common/rpc.Dialer.dial:188\n\tstorj.io/common/rpc.Dialer.DialNodeURL:148\n\tstorj.io/storj/storagenode/contact.(*Service).pingSatelliteOnce:124\n\tstorj.io/storj/storagenode/contact.(*Service).pingSatellite:95\n\tstorj.io/storj/storagenode/contact.(*Chore).updateCycles.func1:87\n\tstorj.io/common/sync2.(*Cycle).Run:152\n\tstorj.io/common/sync2.(*Cycle).Start.func1:71\n\tgolang.org/x/sync/errgroup.(*Group).Go.func1:57”

Nope. Uptimerobot reports it as down too.

Negative, since its down every node should be seeing this. IMO it needs to be removed from trusted-satellites list too to fix it. This is not critical though as it doesn’t hamper node performance in any negative manner.

At last, this is not related to changelog of 1.12.3 either so this should have been a new topic.

well I just can’t get anything right,

also it’s making my logs fugly

:wink:

3 Likes

sorry small yellow bus here :wink:

Heyo
Been doing some maintenance work on my storage node(mainly router problems), and I have been noticing a high number of “contact:service ping satellite failed” errors. The satellite ID field points to the stefan-benten satellite, so I suspect this may be caused by the shutdown of this satellite?

Regardless, do I need to take any action to resolve these errors, or can I safely ignore these?

Same here:

2020-09-17T10:56:03.128Z        ERROR   nodestats:cache Get stats query failed  {"error": "node stats service error: unable to connect to the satellite stefan-benten: rpccompat: dial tcp 78.94.240.189:7777: connect: connection refused", "errorVerbose": "node stats service error: unable to connect to the satellite 118UWpMCHzs6CvSgWd9BfFVjw5K9pZbJjkfZJexMtSkmKxvvAW: rpccompat: dial tcp 78.94.240.189:7777: connect: connection refused\n\tstorj.io/storj/storagenode/nodestats.(*Service).dial:159\n\tstorj.io/storj/storagenode/nodestats.(*Service).GetReputationStats:66\n\tstorj.io/storj/storagenode/nodestats.(*Cache).CacheReputationStats.func1:153\n\tstorj.io/storj/storagenode/nodestats.(*Cache).satelliteLoop:259\n\tstorj.io/storj/storagenode/nodestats.(*Cache).CacheReputationStats:152\n\tstorj.io/storj/storagenode/nodestats.(*Cache).Run.func2:119\n\tstorj.io/common/sync2.(*Cycle).Run:92\n\tstorj.io/common/sync2.(*Cycle).Start.func1:71\n\tgolang.org/x/sync/errgroup.(*Group).Go.func1:57"}

Hello,

satellite is down - just ignore this error
more info:
http://storjnet.info/

2 Likes

Well that’s weird, I’m not facing this issue on any of my nodes :no_mouth:
(EDIT: Well I am, see 2 posts below, thx @nerdatwork)

I mean when reopening an existing tab showing the dashboard on mobile, it shows offline and I do have to refresh the page for everything to update correctly (and for it to display “online”), but this bug exists since as long as I can remember…

Have you checked the log for contact:service error ?

1 Like

Ah sorry my bad, I did not realize you were referring to log errors.
I do have dozens of “ERROR contact:service ping satellite failed {"Satellite ID": "118UWpMCHzs6CvSgWd9BfFVjw5K9pZbJjkfZJexMtSkmKxvvAW", ...” too, yes indeed.

What I meant is that none of my web dashboards have issues displaying “Online”, node ID, or any other piece of info. They just work.

does anyone if by uncommenting the following config file will eliminate that error,Screen Shot 2020-09-18 at 07.02.06since it’s it has been deauthorize ,

just a thought

That list is already used and every time node starts up it downloads that list from the URL. Unless Stefan’s URL is removed from trusted-satellite list the error won’t go away IMO. The satellite is going to be repurposed so all this worrying is not helpful for your node’s health.

Don’t try to fix something that is not affecting your node in any negative manner. You might end up breaking something.