Uplink Setup Error

When I tried to setup uplink it works well but at the last shows this error.

Imported access "main" to "C:\\Users\\Karan102\\AppData\\Roaming\\Storj\\Uplink\\access.json"                           Switched default access to "main"                                                                                       Would you like S3 backwards-compatible Gateway credentials? (y/N): y                                                    uplink: register access for edge services failed: access grant: disallowed satellite "1WsExd5kCt1RqkYNpZFF1HJwBzmWjs8zSs6ju7NDJsGzfe66UX@"                                                                                               storj.io/uplink/edge.(*Config).RegisterAccess:91                                                                        main.RegisterAccess:227                                                                                                 main.(*cmdAccessSetup).Execute:104                                                                                      main.(*external).Wrap:353                                                                                               github.com/zeebo/clingy.(*Environment).dispatchDesc:106                                                                 github.com/zeebo/clingy.(*Environment).dispatch:52                                                                      github.com/zeebo/clingy.(*Environment).dispatchDesc:59                                                                  github.com/zeebo/clingy.Environment.Run:34                                                                              main.main:35                                                                                                            runtime.main:250 

The register access grant command requires working Edge services, authservice and gateway-mt specifically.
Did you manage to setup them in this thread:

if not, the register will not work too.
I invited team members to that thread for storj-sim and Edge services, since I have no knowledge how to integrate Edge to storj-sim.
However, I know, that Edge services are working in storj-up.

Hello @Alexey

No I didnt get solution in this thread too

It would be great thanks …

Hello @Alexey I get the solution of previous thread.

But this Uplink Setup Error is still disturbing me please help me to solve this issue…


You need to configure uplink to use your local Auth service instead of ours

    uplink setup [--auth-service string] [--force] [--use]
        --auth-service string    If generating backwards-compatible S3 Gateway credentials, use this auth service (default https://auth.storjshare.io)

It also should be supported as an option in the config.yaml (placed to the location for --legacy-config-dir option).
You may check default locations like this:

uplink setup --help --advanced | grep "legacy-config-dir"

or for PowerShell

uplink setup --help --advanced | sls "legacy-config-dir"
1 Like

Hello @Alexey

What should be input for --auth-service?

When can I find it?

It’s an listening address for your Auth service, I believe it’s http://localhost:7772 in your setup

1 Like

Yes but I have reconfigure all and now my updated setup is

authservice run ^
   --allowed-satellites 1Yfzd9me7ztdNAYhNu9New4MEVTv6RA1DrLMWmwhHDoykVcg8h@ ^
   --auth-token my-test-auth-token ^
   --endpoint http://localhost:8002 ^
   --listen-addr :8000 ^
   --kv-backend badger://
gateway-mt run ^
   --auth.token my-test-auth-token ^
   --auth.base-url http://localhost:8000 ^
   --domain-name localhost ^
   --server.address localhost:8002 ^

I have run this

uplink setup --auth-service http://localhost:8000

but it gives me an error like this:

uplink: dial to auth service failed: rpc: address http://localhost:8000: too many colons in address

What is that?

Did you use a correct address? I thought it has a port 8001

1 Like

Hello @Alexey

There is no such configuration donefor port 8001 I have used 8000 and 8002 for authservice and gateway-mt run

Hello @Alexey

Any suggetion on this error.

You need to add your satellite to the allowed list on authservice either with an argument --allowed-satellites=1WsExd5kCt1RqkYNpZFF1HJwBzmWjs8zSs6ju7NDJsGzfe66UX@ in your authservice run command or with an option in the authservice’s config.yaml file:

allowed-satellites: 1WsExd5kCt1RqkYNpZFF1HJwBzmWjs8zSs6ju7NDJsGzfe66UX@
1 Like

So I have to do uplink setup after run authservice …?


If you have already setup it - you may just try to use it. Make sure that authservice has this option loaded (you need to restart it).

1 Like

Okay, Let me try …