V1.75.2 QUIC misconfig issues

No network changes over the past 6 months and everything has run reasonably well till now. Occasionally I’d find the STORJ docker stopped. I’m not sure what that’s about but it only happens about once per month.

This QUIC misconfig issue has been happening since about Monday. It randomly goes down and then restarting or start/stopping doesn’t seem to help. I need to leave it off for a few minutes before starting and it usually resolves the problem.

Curious if others are having the same problem.

1 Like

Interestingly, other satellites are still operating.

Sometimes I have the same problem after update I am running also on docker

This error indicates that your node cannot receive UDP traffic. It could be your router or ISP.

You may also just refresh a dashboard - it re-check QUIC on each check-in on the satellites (every hour).

I’ve let it run misconfigured for 12 hours or so and since we recently started a new month I’ve found the egress is working well but ingress is at 0. It seems Upload is the only part working…

0 ingress, with any egress, usually means the version is too old or the node thinks it’s out of space.

Please post the lines from the log after (re)starting your node.

1 Like

I’ve checked for updates and it says the version is up to date. The drive is nearly full, I think it keeps about 20-30gb free and that’s what it’s at.

I just stopped/started and then restarted the node and now QUIC is OK and I’m getting ingress again.

1 Like

Since the last update, QUIC is misconfigured again… no idea what is going on.

Restart - QUIC OK. like…

annnd misconfigured again.
restart - - QUIC OK…

Sounds like unstable UDP connection in your network. May be you have some extended security enabled on your router (DDoS protection, etc.).

Nothing has changed over the past few months regarding network infrastructure. If it were filtering UDP I’d assume it’d be consistently down and not working for the first 5 minutes and then down after that.

uptime 4h4m and QUIC is OK.

I guess it could depends on the load.

Hi. I would check if no change on your router or ISP.

I had this few months ago and it was fight. Check what I have tried and what worked for me:



Hopefully you will find solution to your issue.


1 Like

Still nothing. I’ve found a DOS filter that I disabled but it didn’t really change anything.

Perhaps your router has several similar features as pointed by @LordWigo or even your ISP have something similar.
I noticed, that some ISPs started to implement “smart” protection for their customers, blocking any income traffic.

Here’s my issue with that - if I restart the storj docker instance it works for some time before switching to ‘misconfigured’. If a firewall rule had blocked UDP it shouldn’t be working at all, shouldn’t it?

yes, but with some kind of throttle grey-list - it’s likely be expected.
So I would check these options on the router or firewall or antivirus.

By the way, there is no point to check the node’s activity - all data is encrypted anyway and your node stores only 1/80 piece of the segment (!) of the file. Just waste of CPU cycles on checking its activity.

Oddly, it’s been up for 9 hours now and QUIC is ok. No idea at this point.