WAN IP address different than external address

So my WAN IP address in my router homepage is different than my external address in https://www.yougetsignal.com/tools/open-ports/

And I think this is the reason why the node I setup is offline. My port is correctly forwarded in the router site (forwarding > virtual server - using a TL-WR840N)

Service Port IP Address Internal Port Protocol Status Edit
28967 myprivateIPaddress 28967 TCP Enabled

please advise.

Do you have static or dynamic IP address?

in the router page in ‘IP address’ (in the WAN section) it says ‘dynamic IP’

It doesn’t mean anything yet. The point is that the address for your router is set automatically by your ISP’s DHCP server. If you don’t know if you have a static or dynamic address, you have two solutions:

  1. Contact your internet provider and ask about it.

    • Go to https://api.ipify.org/
    • Save current IP address
    • Come again to this site in a while
    • Check if the address has changed

but the reason why we use and setup an account in https://my.noip.com is to solve this problem right?

for the record this is my config:

-e WALLET="0xf....." \
-e EMAIL="myemail@gmail.com" \
-e ADDRESS=" myaddress.hopto.org:28967" \
-e BANDWIDTH="10TB" \
-e STORAGE="1.62TB" \

etc

Exactly. If you use no-ip it means you probably have a dynamic IP address.
Run your node and check what problem is showing in the logs.

ubuntu@ubuntu:~$ docker logs storagenode

2020-02-02T12:42:21.286Z INFO Configuration loaded from: /app/config/config.yaml
2020-02-02T12:42:21.289Z INFO Operator email: emailgmail.com
2020-02-02T12:42:21.289Z INFO operator wallet: 0x…
2020-02-02T12:42:22.188Z INFO version running on version v0.31.12
2020-02-02T12:42:22.212Z INFO db.migration Database Version {“version”: 31}
2020-02-02T12:42:22.800Z INFO preflight:localtime start checking local system clock with trusted satellites’ system clock.
2020-02-02T12:42:24.692Z INFO preflight:localtime local system clock is in sync with trusted satellites’ system clock.
2020-02-02T12:42:24.693Z INFO piecestore:monitor Remaining Bandwidth {“bytes”: 10000000000000}
2020-02-02T12:42:24.694Z INFO bandwidth Performing bandwidth usage rollups
2020-02-02T12:42:24.694Z INFO trust Scheduling next refresh {“after”: “7h26m8.138645014s”}
2020-02-02T12:42:24.695Z INFO Node myNodeID started
2020-02-02T12:42:24.695Z INFO Public server started on [::]:28967
2020-02-02T12:42:24.695Z INFO Private server started on XX.XX.XX.XX:7778
2020-02-02T12:42:24.814Z INFO version running on version v0.31.12
2020-02-02T12:46:12.945Z INFO Got a signal from the OS: “terminated”
2020-02-02T12:47:22.391Z INFO Configuration loaded from: /app/config/config.yaml
2020-02-02T12:47:22.401Z INFO Operator email: myemail@gmail.com
2020-02-02T12:47:22.402Z INFO operator wallet: mywallet
2020-02-02T12:47:23.082Z INFO version running on version v0.31.12
2020-02-02T12:47:23.280Z INFO db.migration Database Version {“version”: 31}
2020-02-02T12:47:24.004Z INFO preflight:localtime start checking local system clock with trusted satellites’ system clock.
2020-02-02T12:47:26.687Z INFO preflight:localtime local system clock is in sync with trusted satellites’ system clock.
2020-02-02T12:47:26.688Z INFO trust Scheduling next refresh {“after”: “5h51m12.904261868s”}
2020-02-02T12:47:26.689Z INFO bandwidth Performing bandwidth usage rollups
2020-02-02T12:47:26.694Z INFO Node myNodeID started
2020-02-02T12:47:26.695Z INFO Public server started on [::]:28967
2020-02-02T12:47:26.695Z INFO Private server started on XX.XX.XX.XX:7778
2020-02-02T12:47:26.813Z INFO piecestore:monitor Remaining Bandwidth {“bytes”: 10000000000000}
2020-02-02T12:47:26.814Z INFO version running on version v0.31.12

address have not changed. I updated the config to

-e ADDRESS="that_external_address:28967" \

still node shows offline.

Identity is signed?

Now I have to fill in garbage to be allowed to post this.

not sure what you mean with ‘signed’. i followed all this https://documentation.storj.io/dependencies/identity

and I have this setup

--mount type=bind,source="/home/ubuntu/<my folder with the identity files>",destination=/app/identity \

Did you receive a token by email and used the ‘authorize storagenode’ command?

yes, i did this (from another computer, not from the one where I will run the node -a raspberry-

./identity_linux_amd64 authorize storagenode <email:characterstring>

i can do it again if needed

It can be done only once. Check how many files do you have in your identity folder.

In this case your ISP most likely uses CGN and your port forwarding in your router will have no affect. In this case you need to use a service like portmap.io.

Who is your ISP?

1 Like

Before you go this route it is worth it to call your ISP and ask to get a public IP instead of CGN. A surprising amount of people have had success with this by just asking. If they don’t help you with that, consider how much you love your ISP and what other options are out there or use portmap.io.

1 Like

three files: ca.cert, identity.cert, identity.key

whats the difference between this and NoIP suggested in the documentation (and which I already enabled?) https://documentation.storj.io/dependencies/port-forwarding

writing them a mail.

by the way - i checked again on https://api.ipify.org/ and public address is the same, so seems is static.

NoIp can solve the problem with a dynamic public IP. You will have a hostname, which you can use instead of IP as your external address. This hostname will be update by your router if you configure it to do that or with an application of the DDNS provider, in case of no-ip it’s called DUC. It doesn’t help, if your WAN IP is differ from the public IP.
The portmap.io can help you in case, if your WAN IP is different from the public IP. If you will use it, the DDNS will not be needed, because you will have a hostname from the portmap.io

2 Likes

The difference is, that if your ISP uses CGN, you basically sit behind another NAT router and your router will not be reachable from the Internet. With a service like portmap.io you establish a VPN connection to them and then you setup a portforwarding at their end and they route all packets through the VPN tunnel to you.
But reading your last comment, your IP from your router matches the reported IP from ipify.org. Who knows what happened earlier (browser cache?).